64bit computers render ok, 32bit computers crash Blender


I’m rendering a pretty big scene with a lot of textures. My 64bit computer can handle it just fine, allthough the render time is 3mins/frame.

I would like to have some rendering aid from my 32bit laptop, but I guess the scene is too much for it, since rendering always crashes Blender after a few minutes. I tried to render also on another 32bit computer/32bit Blender and that one crashed too.

My question is: is there maybe some setting I can change in Blender in order to help my 32bit renders survive?

Is it shutting off because the processor hot?

It’s probably crashing because the rendering process is needing more than 2 gigabytes of RAM (which exceeds the max amount that 32 bit systems are capable of using)

The only ways out of this is to

  • Change your rendering settings to be more memory efficient

  • Convert any situations where a large number of identical objects are being used to make use of instancing, which allows a large number of identical objects totaling millions of faces to be rendered using a much smaller amount of RAM.

  • Reduce the polygon count (which may have undesirable effects in the form of missing detail)

Thanks for your help!

Ace Dragon, when you say “Change your rendering settings to be more memory efficient” do you mean turning off certain features like raytracing, or are there settings that affect only the way Blender handles memory (without affecting my actual image quality)? If it’s the latter then I’m all ears on how to do that! If you mean turning off render-intensive things like subsurface scattering or anti-aliaising, then that I can’t do since my other computer has already rendered 600+ frames now and the style of the animation can’t change in the middle of the animation…

I also decided to try installing Linux Ubuntu as a dual boot on my laptop and after a lot of hassle (never really used linux before) it seems like my laptop might survive the render :spin:

The latter, usually by changing the raytree that the renderer uses and ticking the options available to save memory such as saving the buffers and a couple of other options to save memory during compositing (though saving memory usually comes with somewhat increased rendertimes)

Sounds great!

I’m staring at the performance tab right now. Can you give any tips on which of the following features should be ticked in my situation (running out of memory)?

[ ] Save buffers
[ ] Free image textures
[ ] Free unused nodes

Acceleration structure is currently set to “auto”

[X] Instances
[ ] Local coordinates


Any tips would be appreciated!

Save buffers will reduce the amount of memory used when rendering the scene at the cost of a slightly higher rendertime, the last two are for saving memory when the image is being composited.

The acceleration structure that provided the best combination of speed and memory usage is the SIMD QBVH tree, SIMD SVBVH is faster, but uses more memory, the ones below may not take as much memory, but are a lot slower.

Do not check Local Coordinates if memory is an issue, while it may make rendering go faster, it increases memory usage.

Leave instances on, this is needed if you want to use instances to reduce memory usage.

As far as know, there’s no measurable effect on the amount of memory used when the number of tiles are changed (though may cause some effect in rendertime especially when it splits areas that take a long time to render)