A beginner's problem: three chains can't hold a ring


I am trying to accomplish something that in my mind should be very simple: to get a torus ring to be held by three pieces of chain. Here’s the initial setup:

The small ring on the left holds all three pieces of chain, being a non-dynamic rigid body. Everything else is dynamic.

Here’s what happens when I play the animation:

Nothing I do seems to be able to keep the large ring from falling, as if it wasn’t bound by the laws of physics. Obviously I’m doing something wrong, but I can’t see what. I even tried inserting three small rings (in edit mode), "binding"them to the big ring, but to no avail.

Here is the .blend file, in case someone feels like taking a look:


Can someone point me in the right direction?

Thanks, and have a great day!

Try scaling everything up, and cranking your substeps way up in the rigid body world panel.

Thanks for the prompt reply!

Alas, if I did what you suggested correctly, it didn’t work: went up to 5000 in steps per second, and to 1000 in solver iterations (after scaling everything up ten times). Even tried “Split impulse”, even not knowing what that does. In every single value of those variables the chain breaks at some point. Also, I tried varying the mass of each link, as that seems to help keep integrity in some cases.

Moved from “General Forums > Blender and CG Discussions” to “Support > Particles and Physics Simulations”

Just apply scale to the big hoop and the 3 ones it attaches onto and it should work ( it does on my end)

(select them, then press ctrl a, then click scale)

edit again:
this works for the scale in the file you uploaded, but i tried scaling it to 0.1 and applying the scale and it breaks again.

It works! Thank you, @forferdeilig!