A display problem of script windows... Solvable ?

Hi,

I have the following problem with my script windows within Blender (any script):
They sometimes display the GUI properly, and sometimes the way it is pictured as attachment (LuxRender in that case).

I run 2.48a or SVN (no difference) in a Q6600 Intel and a X1950Pro ATI card.

When i hover the mouse on the window, the buttons underneath the pointer appear, only to leave when the mouse leaves the window…

Is it a known issue ?

Attachments


I dare to up this post…
HAsn’t anyone encountered this very problem ?

got the same problem.it could be a bug of version 2.49.I hope someone gives us the answer we need 'cos this bug or something is so annoying

hi, I’ve tested nearly all scripts with my ATI Raedon 4800 series.
Also with Intel 4500m onboard.
This is not a Blender problem.
It is a problem with Graphics Drivers.
I have not been able to reproduce this error.
Tested over 300 script interfaces.

Yes, It has nothing to do with Blender I think.

I’ve downgraded my ATI drivers to Catalysts 8.5 an dthat particular bug is no more (but this brought other problems)…

I am afraid the devs can’t do anything about that… Seems to be OpenGL on ATI related.

Is there a way to fix this by any tweaking in Catalyst Control Center settings?

Well, I couldn’t.

Using Catalyst 8.5 helped that particular issue, but the texture distorting thing is still here and I wasn’t able to work with large image textures (2000*3000 picts froze Blender)

So I’m bak with 9.3 and this nuisance…

Boy, my next card is gonna be an nVidia ! Too much trouble with Blender/ Linux on my ATI.

Hi…

I’'ve posted my solution on my blog (I’m using 9600xt). I’m not sure what cause it.(Maybe something to do with ATI antialising or temporal aa or any other stuff?)

Install ATI tray tools and try to tweak according to the registry/or setting

[HKEY_CURRENT_USER\Software\Ray Adams\ATITrayTools\Profiles\d3d\myProfileMax]
“FlipQueueSize”=“1”
“SwapEffect”=“0”
“LODAdj”=“0”
“ASTT”=“1”
“ASD”=“1”
“AreaAniso”=“1”
“AntiAlias”=“2”
“AntiAliasSamples”=“6”
“AnisoType”=“0”
“AnisoDegree”=“16”
“TextureOpt”=“0”
“TextureLod”=“0”
“VSync”=“1”
“TruformMode”=“0”
“PixelCenter”=“0”
“ExportCompressedTex”=“1”
“ExportBumpMappedTex”=“1”
“AnisotropyOptimise”=“1”
“TrilinearOptimise”=“1”
“CatalystAI”=“1”
“GI”=“1”
“ATMS”=“2”
“TemporalAAMultiplier”=“2”
“TemporalAAFrameThreshold”=“0”
“EnableTripleBuffering”=“1”
“ForceZBufferDepth”=“0”
“OGLCustomSwapSourceFile”=""

Mine, running smoothly without any GLSL glitches and random layout problems for few days (I use blender everyday). Please let me know either its help or not.

I’m still having sculpting problem with most builds - something got to do with screen space stuff - and I think those problem are related to the same matter (ATI layer?).

Thank you.