A huge! modelling problem that has been annoying me since the old blender!

The lack of face splitting support!, I find I need to perform extremely weird methods to create a mesh whenever I try to split a face with more than four vertices. When I manually add vertices and connect them to create tri’s/quads it just completely wrecks the subsurface modifier. How can I combat this? I am trying to create a model for an interview with a college next week.

The lack of face splitting support!,
In what way ?

I find I need to perform extremely weird methods to create a mesh whenever I try to split a face with more than four vertices.
In what way ?

When I manually add vertices and connect them to create tri’s/quads it just completely wrecks the subsurface modifier.
In what way ?

How can I combat this?
Show us what the problem is (clear screenshots and example blend files showing what the problem is and the result you are wanting), otherwise we’re all in the dark here!

Use the knife tool - K and draw the places you want your face to be ‘split’ then press enter to confirm. That is, if it is what you are looking for. BMesh is awesome.

Tab into edit mode and hit CTRL+N to correct your normals. If that is not your problem, see what Richard said.

I created the split in the middle by adding the vertices manually, replicating the problem I ma having (not the actual problem on modal)

non subsurf’d image:



Subsurf’d:


vertices:

I tried using ctr + N but that didn’t work, I will try using the knife tool

Yes, that is extremely hard.
For example, I have two ngon faces next to each other and I realize I need to reconnect some of the vertices on both of them (marked in red)


I need to select vertices and press the J key once, which is outrageous. Give me my money back.

Joking aside. Ngon faces can exist with subdivision surface like triangles can, they just need to be positioned such that they don’t cause troubles. On a flat surface, surrounded with quads.
Using ngons is more like a way to the result, not the result itself, and should eventually be converted to quads.

If you want, you can still use tri/quad mode when subdividing individual faces for example. Just have to enable it from the operator panel (tool shelf or F6).

:smiley:

Darn, have to type more. (Yes, I said darn.)

Whilst I think about it; annoying you since the old blender: which version do you mean?

And forgive me, but you wait to join and complain until now; that doesn’t suggest much annoyance to me.

just gonna remove this thread since I get more grief than help, thanks for the knife suggestion that works fine and all the rest. I am entirely self taught with blender so there are some things that I haven’t learnt…

No idea what you’re talking about “since the old blender” considering you couldn’t even have faces with more than 4 verts until very recently…