A labyrinth of black lines[IMG]http://i103.photobucket.com/albums/m143/WarKirby/black

One of the most frustrating issues in blender has cropped up again, bringing my latest project to a grinding halt :mad:

Every texture I bake looks like this.

Hundreds of little black lines, all over it. Every single one is an exact diagonal across a face, from one corner vert to another. It wasn’t happening yesterday, I don’t know what I did to cause it, but I can’t seem to undo it now.

Although it’s possible to manually remove them in photoshop, this takes a frustrating amount of extra work, and is completely unacceptable. I need to find the cause of this.

The last time I made a thread about this, someone concluded it was an issue with AO, and a bug in blender. It wasn’t anywhere near this bad, though. My AO settings can be seen at the bottom of the image.Though I’ve tried with many different settings.

Changing the AO mode to approximate, makes the lines much fainter, but they ARE still there. It also destroys much of the rugged, “textured” look, that is essential for this.

Can anyone please tell me what’s wrong? I can’t do anything like this :frowning:

Edit: ARG< I fucked up the thread title. My bad.

Nice pattern, keep it like that:D
I got no idea…

Hmm… if I’m not wrong that is the pattern Blender follows during “work in progress” of the bake process. If you look at it during baking you can spot Blender fills those area in a
pattern similar to what you have there.

But if you let it finish the image is completely filled and the pattern’s gone away, so I can think about a bad build?
What Blender version are you using?

I would also try increasing the “margin”-value, to be sure it’s not simply the border of a face which is not baked any more because it’s only half under the face oder something like that.

ShilaM: I’m pretty sure you’re right. They’re parts that start off black, and just aren’t being filled for some reason.

Blender 2.47

Built on 2008-08-17 10:02:36, Rev- Version win32 dynamic

This is what help > about blender says

I tried increasing the margn value, no effect

It seems 2.47 Official so I’d exclude bad build but anywway, my only two advice:
try and re-download Blender, or change your image resolution and give it a try.

If nothing changed you could consider adding a bug report in the tracker.

Ok, uninstalled blender, downloaded a fresh installer, and reinstalled it. No change,

Did some more experimenting though. I’ve found some interesting things.

  1. If I create a new object in the scene, and bake it. This problem does not occur. Even If I apply the same material as the problematic objects. This pretty much removes any blame from the scene, my AO settings, or the material.

However, if I duplicate the problematic objects, it still occurs on both copies. :frowning:

  1. Possibly not even related. After a bake, the shoulder pad deforms. The bounding box changes sizes considerably, squashing it up. Transform properties dialog shows different values, so something is being changed there. But if I do any transform operation on the deformed object (position, scale, rotation) it immediately reverts to the normal size. It only stays that way if I commit the transform though. Cancelling it returns it to the deformed shape.

Here’s an example.
I duplicated the shoulder pad. The one on the right has become deformed. They were both the same shape before I baked the texture. Since when has texture baking ever affected the shape of an object?

Lastly, I’m not sure how much can be done with just my descriptions, so here’s my .blend file. I hope it can help someone find the issue :frowning:


I’ve had a look at your .blend and I found a lot of duplicated vertices (60 dup!) in the “incriminated” object :slight_smile:
Assuming that DOES NOT explain the strange mesh deformation, it can explain otherwise the baking issue.

So you really should enter edit mode, select all of mesh’s vertices and hit Rem Double in the Mesh tools panel, recalculate Normal outside with all your vertices selected and “Ctrl+N”, then rebaking and give it a try.

I hope it could help!

This looks VERY similar to the weirdness I got when playing with LuxRender. See thread: http://blenderartists.org/forum/showthread.php?t=129547


Removing vertices is not an option. I’m creating meshes for second life, and an exct number of vertices, no more, and no less, are required. I’m certain it’s not the cause though. Everything was baking perfectly to begin with, and I made no mesh adjustments since this issue ocurred. Also, the problem occurs on all of the other parts of the armor, too.

Most of the doubled vertices are bunched around the poles on the shoulderpad, anyways, the black lines ffect occurs all over the mesh.

Skwerm: I don’t think that’s the same issue. The black lines that I’m having issues with are always diagonals across a square face. Never perpendicular to edges. The ones in you thread appear to be straight.

The only way I can find to fix this, is to disable AO completely :frowning:

I perfectly understand those requirements but my objection is double vertices lead soon or later to having some issues and they are absolutely to avoid in every your model.

Otherwise, assuming your latest post I think it could be interesting to submit your “bug”, if this is the case, to the bug tracker and let us know what appened. :slight_smile:

I’m making some try with my files but with or without AO I never got that issue.

here’s my try:


this is the moment when Blender has covered the entire area of the image
with colors and “holes” and now it starts to fill those holes.
AO is enabled so textures and Normal map.
In the image there are my Bake settings too.

Hope it could help.