A little dilema with drivers...

Recently, I purchased a new gaming PC. It works great, can run just about anything (save for Crysis, of course :p) maxed out, and actually likes to cooperate with me. So it came as a shock when Blender decided it was going to run at about ten FPS. After a bit of Googling, I found out that Blender doesn’t support DirectX, which doesn’t make much sense to me. It worked fine on my old Dell of considerably less graphic power, which was running DX as well. So I went searching for an OpenGL driver, downloaded it, and was sorely disapointed to learn that it didn’t run any faster. Being too lazy to continue with it, I attempted to start up FarCry 2, which would not run because my drivers were out of date, so I had to reset them back to DX drivers. I figure this meant that the drivers must have been too old to run Blender any better than my DX drivers.

So now my problem is what driver to run Blender on? DX apparently can be made to work, if my old Dell could do it, I refuse to believe my new one couldn’t. DX is also considerably better for gaming (many games won’t even run on some other drivers), which is the main reason I own the computer. Unless there’s a way to dual-boot drivers for certain applications (in which case, I’ll need a link to some current OpenGL drivers), I’m sticking to DX. So I suppose my real question is how to run Blender well on DX drivers?

Here are my system specs, if it helps anyone:

  • MSI 750a Platinum edition motherboard
  • AMD Athlon 64 X2 6000+ dual-core processor
  • 4GB RAM
  • Nvidia GeForce 9800 GX2 graphics card
  • 320 GB Western Digital Caviar 7200 RPM
  • Windows Vista Professional Edition 64-bit

Hello
you’re a bit confused I guess?!
Dx is a proprietary technology that only works in windows OS!
Open GL is a free standard that works in many platforms, like Blender!
When you install your graphics card drivers, a “Open GL driver” will be installed too ( most probably, the best one!?).
Blender is a “slow” game engine, that’s all!
Bye

Blender does not support DirectX and it never will. DirectX is proprietary and the property of Microsoft. Blender is free and open source and runs on Unix (Mac OSX, BSDs, and Solaris), Linux, and Windows.

It is a bit suprising that an NVidia is behaving this way, as usually they are really nice. It might be a longshot, but you could try disabling Vista’s Aero, as it may be the source of the slowdown.

For some reason, (in addition to setting my theme to Windows Classic) enabling Aero seemed to solve my problems… Strange, huh?

I don’t know Vista, but perhaps enabling Aero enabled hardware acceleration/hardware rendering.