A little problem with compositing and DOF using Blender Internal

Hi everyone! This is my first post in the forum, I hope to be doing things well and be able to contribute and learn a lot here in the future :slight_smile:

I have a problem with DOF using Blender Internal. In the compositing window, I get some strange lines on the lighter areas. DOF effect should recreate soft blur at the contours, so I can’t know why these “lines” appear.

I attach a screenshot of the detail and the node setup.


Try disabling the ‘preview’ option on the z-depth node…

if you can upload your blend file to pasteall.org/blend that would be great, that way we can debug the file



OMG, it worked!

Disabling “preview” fixed the problem. Now DOF defocus works perfect and it’s really smooth :slight_smile:

Thanks a lot :slight_smile: