A new fork of the engine


(ADVANCESSSS) #1101

Nice to see that BPR. It would be better to see the effect on a smooth high-res human model with a full hd texture though. Then we can also see if there is any need for improvements.

What about an object reflection its light onto other objects? What about multiple bounces (maybe 1 bounce)? What about just making a real trace system for lights instead of cubemap hacks?


(JustinBarrett) #1102

Am I hallucinating or has there been a bug fix release of UPBGE 0.2…I now see a download for 0.2.1…is that correct?

Yes, i was correct…I’m having a lot of problems with it though…I may need to update my dependencies…I’m on linux…any other linux user have any problems?


(Akira_San) #1103

Yes, its Upbge 021 :slight_smile:


(tristan73) #1104

Hello everyone,

As some of you already seen, UPBGE 0.2.1 was released. The major effort in this release was dedicated to simplify the meshes with modifiers render.
Else some features as render queries and some physics option were implemented, for more details see the release note: https://doc.upbge.org/releases.php?id=0.2.1

The builds are available as habits from: https://download.upbge.org/.


(mataii) #1105

Thanks a lot for the update tristan73 :slight_smile:


(BluePrintRandom) #1106

thank you tristan!
(awesome that your tackling physics)

any chance at btMultiBody constraint in the future?


(m5ables) #1107

amazing and perfect

we should support you

thank you so much :smiley:


(mataii) #1108

Have you ever noticed this?

Using a mouse movement sensor linked to a motion sensor with either, movement or rotation, it rotates even when you are not moving the mouse.

It seem that the sensor keeps sending a pulse every second (activated or not with true pulse mode), this happens with BFBGE and UPBGE.

here is a blend. mouse_movement_bug.blend (459 KB)


(Daedalus_MDW) #1109

i notice something similar when using the viewport player.

does this occur when using standalone/fullscreen?


(JustinBarrett) #1110

I’ve got no ui buttons or header(file view etc) on linux…I may need to open an issue on git hub…I will investigate a bit more first.


(m5ables) #1111

if i run UPBGE in linux

https://preview.ibb.co/i8pjgG/Screenshot.png


(tristan73) #1112

@JustinBarret, @m5ables: please post the console log.


(m5ables) #1113

this is my console log

https://file.io/ZJbJvX


(m5ables) #1114

this is my console log

https://ufile.io/gehpn


(tristan73) #1115

Hello,

@m5ables: New linux build are updated with python binary linked against static libraries. Please confirm that it works for you.


(m5ables) #1116

hello tristan73

it is working now

thankyou so much :smiley:


(JustinBarrett) #1117

Yes, mine is working…I had trouble updating python after that it worked…but this build also works…so…thanks either way :slight_smile:


(JustinBarrett) #1118

under UPBGE 0.2.1b when ‘show render queries’ is enabled I am getting about a 60-70% frame rate drop…it is not a showstopper by any means, but is this expected behavior? If not, I will report it…although this coud be due to my large scene and amount of objects…


(blender_user) #1119

Hello, Can someone help me?
The latest upbge 2.1 not running because need GLIBC_2.23 and say that
UPBGEv0.2.1b2.79Linux64/blender: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.23’ not found
I’m on ubuntu 14.04 i have GLIBC 2.19 .
it is possible compile with older glibc version as upbge 2.0 is, and possible choice from list in future from this site?

https://download.upbge.org/

thank you guys :slight_smile:


(tristan73) #1120

@JustinBarret: This is a normal behaviour, the render queries request an extra render synchronization to get a valid result.
@blender_user: I’m looking for using old glibc, else when you compile your compiler will use the proper glibc from the system.