A new fork of the engine


(duendecat) #1201

Ah, ok. No more juddering against walls now… thanks!


(duendecat) #1202

Useful to know, thanks.


(billyzill) #1203

Just wanted to chime in and say I briefly tested shuvit on the earlier windows builds and everything appeared to be working as expected. Very relieved considering my massive code base. Very good work. Thanks a lot, and hopefully now some work can get done on the gpu armature skinning :slight_smile:


(tristan73) #1204

Hello everyone

The team is happy to finish the 0.2.4 release with many bugs fixing thanks to numerous feedbacks. This experience was really helpful to make a better release and will be reproduced for next release.

The final release is downloadable from:
https://download.upbge.org/download/release/windows32/UPBGEv0.2.4b2.79Windows32.zip
https://download.upbge.org/download/release/windows64/UPBGEv0.2.4b2.79Windows64.zip
https://download.upbge.org/download/release/linux64/UPBGEv0.2.4b2.79Linux64.tar.xz

The release note is quite similar unless a new option for texture color management:


(mziskandar) #1205

No go for Ubuntu 16.04 LTS.


#1206

Hi @mziskandar I tested the linux build in a Ubuntu 16.04 Virtual machine and it worked for me.

Could you make in a terminal under UPBGE directory “ldd blender” and post here the result?

Thanks


(mziskandar) #1207

Hi lordloki76,
Got this result when I tried to run normally.

ldd blender

…and suddenly, running from terminal as ./blender
It works.

Thanks


(mziskandar) #1208

Hello,
Im using Logitech Extreme 3D, upbge python request for:
logic.joystick[0].axisValues
Resulting only x and y value working…
[x, y, 0.0, 0.0, 0.0, 0.0]
… without trim and trust.
Latest gamecontrollerdb.txt have no effect.


#1209

I inspected the mapping for Logitech extreme 3D and it is only mapped with one axis:
030000006d04000015c2000010010000,Logitech Logitech Extreme 3D,a:b0,b:b4,back:b6,guide:b8,leftshoulder:b9,leftstick:h0.8,leftx:a0,lefty:a1,rightshoulder:b10,rightstick:h0.2,start:b7,x:b2,y:b5,platform:Linux,

The possible solutions is that you map again your controller using tools that i point here (https://github.com/UPBGE/blender/wiki/New-Game-controller-system) or maybe you can modify the gamecontrollerdb.txt including the additional axes:
030000006d04000015c2000010010000,Logitech Logitech Extreme 3D,a:b0,b:b4,back:b6,guide:b8,leftshoulder:b9,leftstick:h0.8,leftx:a0,lefty:a1,rightshoulder:b10,rightstick:h0.2,start:b7,x:b2,y:b5,rightx:a2,righty:a3,lefttrigger:a4,righttrigger:a5,platform:Linux,

The axes in a xbox360 are:
Left stick --> leftx:a0,lefty:a1
Right stick --> rightx:a2,righty:a3,
Gun shoulder triggers --> lefttrigger:a4,righttrigger:a5

If you make it work please, send me the mapping to include it in future versions.


(mziskandar) #1210

Thanks lordloki76

Sorry for the late update. Got it working yesterday, you’ve already taught me about this last year:
Here’s my gamecontrollerdb with hat created in datafiles/gamecontroller

030000006d04000015c2000010010000,Logitech Logitech Extreme 3D,a:b0,b:b4,back:b6,dpdown:h0.4,dpleft:h0.8,dpright:h0.2,dpup:h0.1,guide:b8,leftshoulder:b9,leftstick:h0.8,leftx:a0,lefty:a1,rightshoulder:b10,rightstick:h0.2,rightx:a2,righty:a3,start:b7,x:b2,y:b5,platform:Linux

Thanks


(mataii) #1211

Thanks for the hard work guys :slight_smile:

I was testing the frustrum logic, and it works amazing! I have about 1275 cubes (each one with logic brics) and counting. Framerate and logic load seem to be stable despite the fact I’m using only logic bricks :blush:

The only problem I have is regarding sound, once I export to exe there is no sound.

any one else with the same problem?


(mziskandar) #1212

Hello.
I’m making physic scene.
Runs quite well internally.
As for standalone player, the start maybe skipping frame and burying object underground.
As to overcome this, I will suspend() the scene at the start.
the scene will resume() when the user are ready.
But… seems like resume() is not working - even in logicbrick
Here’s the test file. ‘x’ to suspend and ‘y’ to resume.
mzSuspend.blend (88.3 KB)

Can anyone confirm this?
…or I’m doing it wrong.

Thanks.


(wkk.py) #1213

When you suspend a scene, all its logic is also suspended.

So the sensor/controller/actuator that you setup in that scene won’t execute anymore.

One workaround is to add an overlay scene that will not be suspended, and that will resume the main one when required.


(mziskandar) #1214

Aaa… no wonder. Now its working. Thanks mate!


(Lostscience) #1215

are you using blender v2.79.6 upbge v0.2.3?

could you show me how to use frustrum logic?


(mataii) #1216

I’m using UPBGE 0.2.4 (date 2018-10-06)

Select the object you want to work with “logic culling” , for example a rotating cube.

1.- Go to “Object button” and look for the “Activity Culling” tab and then activate the checkbox “Logic” and put the value you need in “Logic Radius”
2.- Go to “Scene” button and activate the checkbox “Activity Culling”
3.- Select the camera and go to the “Camera” button and look for the “Culling” Tab, and select the “Activity Culling” checkbox

For this I’m assuming you are using the camera as the player, so when you move and are in the object radius range it activates and logic bricks begin to work, and once you are out of range they deactivate.

That’s all :grinning:


(Lostscience) #1217

no I am not using the camera as the player.is that the only way it can work?


(mataii) #1218

No, it does not matter.

I just mentioned that because I did my example with a FPS, but is the same thing for a rpg or any other I guess :slight_smile:


(mziskandar) #1219

Hello.
In UPBGE, why does “Warring: Python components auto-execution disabled” appears when overlay added?


(mziskandar) #1220

Another UPBGE test…