A Proper Keymap for Blender 2.8

It’s ok. You can put the video back in there. I really just did not notice this:
image
That it was a reply :slight_smile:

1 Like

All is fine but i wont put it back because after a second thought i didn’t realize the title of the video was a bit coarse!:sweat_smile:

By the way more on subject i love your keymap, very well thought and as a former 3ds max user i can say it’s the superior keymap so far!

Hi Ludvik
I am unable to select bones while weight painting. Regular Blender keymap is using Shift + Right Click. Buy i couldn’t figure out how to do it. Any advice?
Thanks
Marek

Will check at let you know asap.

Hi, there seems to be a problem with nodes selection: if you have one or multiple nodes selected, click and drag on another unselected node results in moving the previous selection. It works to select the new node just by click then you can click-drag to move it. Another thing is the Knife tool which is missing the E shortcut for a new cut. In a previous comment I was referring to it by mistake as the “cut tool” :slight_smile: Max user here. Thanks!

I’ve tested click and drag on unselected node with some previous selection, but it works fine here. Can you double check?

As for the knife tool, E key doesn’t really exist, but it still shows at the bottom help bar for some reason. Knife works as follows:
RMB: End cut
Double-LMB: Apply
Esc: Cancel

1 Like

Thanks! Knife RMB is alright. I tried reset blender to defaults and reload the addon +keymap but the nodes still don’t work. Even with no selection, dragging over a node doesn’t select it. https://gyazo.com/5dd8bc0e6c3a5d2a0f8224fd86cfb32a

I have downloaded the very latest build and you are right. It appears they broke something yet again. I will investigate and post update as soon as I can. It’s something that’s been changed very recently it appears.

1 Like

No love for grease pencil yet? It seems that there is a conflict with alt+lmb keymap

Yes, I will have to fix that as well, but I don’t really use GP. The GP keymap is a complete hell. It alone is about as large as the entire rest of Blender keymap :confused:

Normally I don’t either, but I tried using it to test out DecalMachine Gpanel. And that’s insane. Let me see if I can figure something out and pass it your way.

Hey everyone,

sorry for lack of recent updates of the keymap. I plan to do a big update once first RC is out. Things were changing way too fast past few weeks, so I decided to wait for RC, which hopefully locks things down for good until new official blender release. So by the end of this week/start of the next one, I will do a big cleanup of the keymap, where I will address also more obscure parts, like gpencil, etc…

5 Likes

Hi,

a new update of the keymap is out. The addon update is required too.

  1. RMB in transform tools in 3D view and in other editors now works as a “tweak tool”. What this means is that RMB click drag now not only performs transform, but also selects what’s under a cursor before hand. This makes it much faster to simply tweak positions or rotations of many elements in a rapid succession with a single click. It comes with a disadvantage though, as you are no longer able to use RMB to perform transform tweak from anywhere on the screen. It will only work if there’s nothing under the cursor. If there is, it will be selected first. I think it’s a a good tradeoff, as the former case is a bit more useful. An example:
    https://youtu.be/_8hMtEeKGm4

  2. Fixed missing ability to select bones in weight paint mode, now assigned to Ctrl+LMB.

  3. Resolved conflict of GPencil and Maya navigation, as well as improved GPencil workflow.

  4. Fixed issue where node editor click drag to move node would not move node if another is selected.

  5. Since the limitation of Node editor only moving one node under the cursor when LMB drag was resolved, RMB drag no longer needs to be transform in node editor. RMB drag is now “cut links”

  6. Since edit modes pie menu (Shift+Tilde) was not very efficient to use, I have returned to number keys for all the individual edit modes:
    image
    Shift+Tilde is still available though if someone is used to it already.

1 Like

@bestelix @Colacuve @Marek_Holly
Hey guys, your issues should be fixed now. Give new keymap version a try!

2 Likes

SUper. idem to testnut. Dik.

Alt+LMB simply does not work at all for me, it shows the blank icon for rotating the view.

I’ve downloaded 2.8 RC1, created portable installation so that it has completely factory defaults. Then I installed the addon, enabled it, and imported the keymap. Everything works correctly on my end, so I guess you may have made some setup error. Did you follow the install instructions?

Nvm it was an addon(probably boxcutter)

thanks for you hard work.
but why the 2d view can not zoom by rmb+alt? why the different than 3d view?

and the " Lasso select Hold Alt+LMB" this no work too~

Lasso has been removed mostly, just forgot to remove it from sheets. It was redundant since 2.8 is heading in the direction of select tool with different modes.

As for the alt+rmb zoom, I assumed most people use mouse wheel. I will try to add that to 2D editors.