A Proper Keymap for Blender 2.8

Hello again! I haven’t yet updated to the latest 2.83 of your keymapping (just haven’t had time yet) but I am very thankful you’re still maintaining this!

I had a question. I use the old 2.80 version but in 2.90 alphas and noticed that when I do an Edge/Vertex Slide by hitting W again after starting to move it that I am not able to use the other hotkeys like E or F to set the options for Even or Flipped in that tool. Hitting E, for example, doesn’t activate the Even option but instead activates the Rotate tool. I looked into the places I could find it in the keymap editor but I couldn’t see anything about those in particular.

I was curious if you had any ideas where those might be or if there was some way to reassign them to different keys, or if there was some method of getting them to work?

No idea. I will take a look once I have time to try 2.90. But as usually, I don’t expect to have usable 2.90 version of the keymap until 2.90 is out of beta. It’s difficult to make keymaps for beta as things change (and therefore break) all the time.

1 Like

It is broken on 2.83 as well, I was just indicating which one I was using currently.

Hmm, I am confused. Not sure what exactly you mean. When I start using move tool and hit W, then nothing happens. Edge slide should be mapped to Shift+S. But that one doesn’t have any Even of Flipped option. How exactly do I activate the one you mean?

1 Like

That’s very odd then. I don’t remember setting that manually. If I’m in the Move tool and hit W it puts it in Edge Slide mode. As soon as I let go of the mouse I see the toolbox pop up showing Edge Slide mode just happened.


In the default Blender keymapping it’s the same (as I understand it) as hitting G again, except ours is mapped to W. But with default Blender keymapping you can hit E to turn on the “Even” option you see in that popup, yet in ours that’s mapped to Rotate so Rotate kicks in instead of “Even”. I hope that makes sense.

That is very strange. I am unable to make that work. It must be some customization of the keymap on your side (or perhaps some preferences setting I don’t know about). In the latest version of my keymap, edge slide is and always was shift + s.

When exactly would I press W? When I am dragging on the gizmo handle? Or just by being in the move tool?

1 Like

I do it after I’ve grabbed the gizmo. Here’s a GIF I just made. I couldn’t get the ScreenCast addon to show my key presses while using the tool but basically I click on the gizmo and start to drag it around, then hit W to enter Edge Slide mode, then hit E in an attempt to go into “Even” mode but it puts me in rotate mode.

I seriously have no memory of setting this up. In fact I don’t even know how I would do that, lol. I just assumed it was part of your keymapping but if it’s not then I guess it’s something on my end.

Yep, that doesn’t happen there. It must be some customization or some specific user setting I am not aware of. Does the shift+s one work for you? Cause in that one, the E and F hotkeys work for me.

1 Like

Shift + S, after clicking on the gizmo in Move mode, puts me in the “Resize” tool.

It’s interesting that your version of it still allows the E key to be used. For some reason my E key is overriding the current tool settings.

Nope, not after clicking the gizmo. Just Shift+S on its own. You don’t even have to be in move tool. If that doesn’t work, then you are probably not using the stock keymap anymore, but something significantly modified.

1 Like

I checked and Shift + S was being overridden by a Cursor + Pivot addon. Even turning that off I still get E overriding with Rotate.

Must be something I changed then. Thanks for at least helping me track down that it was something on my end! I’ll have to try out your new one soon. :slight_smile: