A solid smooth problem

Hi!

I’m trying to model an USB connector and I’ve got some problems with smooth option.

As you can see on two screens -
second one is solid render (nice looking surface but you can see steps on the edges of the connector)
and the first one is smooth render (nice edges but something goes wrong with normals on the top of connector…).

I’ve checked the normals, recalcutate them. I add screenshots of the model. I don’t know what to do to get rid of those nasty shadows shown when turning “smooth” button on.

The mesh is manifold (I’ve checked it by going to object mode and adding “decimate” modifier).

Thanks in advance for your help.

Attachments





A better way to check for manifoldness is to use Select > Non-Manifold in the 3D view menu (or Ctlr+Shift+Alt+M if you are a Sunday’s organ player, non-arthritic kind).
Coincident faces won’t detect as non-manifold: you may want to check for these to with a Wkey > Remove Double (you can undo it afterward) on vertices in the troublesome region.

Jean

Hi greenthumb,

Switch on the “autosmooth” option (in the mesh panel next to the panel where you switch smooth on). Adjust the “degr” value to suit, though the default value of 30 may be OK in this case. Do a few low quality renders to see the affect of changing this value. This will smooth the fillet edges while keeping the top surfaces unsmoothed. You want to find the biggest value where the top surfaces remain unsmoothed to get the best smoothing on the rads.

HTH

This explains it better :slight_smile:
http://wiki.blender.org/index.php/Manual/PartII/Edit_Mode#Smoothing


www.digital-air.co.uk

You should change modeling method a bit, for example when making holes, extrude, scale, extrude down and its best to keep all quad mesh.

http://img233.imageshack.us/img233/2964/p4cr5.th.jpg

This may be related to a similar problem I’m having which is related to the wireframe. Check to make sure your wireframe lines are all there and match your “Edit Mode” lines.

I have no solution yet though. I am using Blender 2.45 and Python 2.5.1.

LHammonds

I’ve managed to do “something” with it. I looked over all modifiers in Blender and one called “EdgeSplit” helped me (although when I used it I didn’t know what does it do :slight_smile: I think it did something like Ardee said.

@IamInnocent
Thanks for saving my time spending on manual manifoldness checking. [BTW - the shortcut seems to be very Unix-like :slight_smile: ]
I’ve followed your advice, checked manifoldness - deleted everything unnessesary, removed doubles, and nothing changed.

@Ardee
As I mentioned in the beginning of my post - I think that EdgeSplit did the same as your method? (or not?)

BTW. I’ve tried to check the “Auto-smooth” option on normal UVSphere and adjusting the “degree”, but I didn’t noticed any changes neither in EditMode nor ObjectMode. Then I realized that changes are only visible when rendering. Is there any possibility of viewing changes of auto-smooth on the fly - in edit or object mode?

@Jurgen
Thanks for your advice - I will now on use your method.

@LHammonds
It seems to be ok with my mesh in wireframe mode… But I do remember that I had a model in which the mesh was missing some of the edges when viewed in Wireframe mode. But in the matter of fact - it didn’t change anything when rendering. I thought that it’s non-significant bug…

Thank you all for your replies.