AAO Problem / Rendering AAO on one layer only?

Im having a problem with AAO at the moment. I have a scene, with a door and a character. The door has a ‘porthole’ where a spot lap shines though with a halo effect.

The problem is that the spot lap creates a kind of ‘AO reflection’ back on the front of the door. Its strange, but ive messed around with it and im sure its the spot lamp and AOO are interfearing with each other.

So really, all i need to do is get the spot lamp to not be included in the AOO calculation. Is there some way of doing this? I thought there might be a way of doing it with the Nodes, telling only one layer to have the AOO calculated.

But im not sure. Any suggestions?

Hmmm, i think ive fixed it. Changed the error tolerance to a lower number (higher quality)

Its annoying spending ages trying to work something out, then posting a thread about it, only to discover whats wrong a few minutes after! :mad:

It would still be interesting to know if AAO can be rendered to specific layers though.

Turn on the AO pass and then reconstruct your image from the different passes using the composite nodes

Ah thats it, i knew there was a feature like that somewhere. Id seen it used before a while back.

Thanks Musk

No Problem. If you want to find out details take a look at: http://wiki.blender.org/index.php/Manual/Render_Passes

The setup of your lamps has no effect whatsoever on AO or AAO results.

Nice, thats what im looking for.

Are you sure? I guess in a way it doesn’t, but as soon as i deleted the spot lamp the unwanted effect was gone. Then it returned as soon as i brought the lamp back. :confused:
Its probubly just some random glitch, or interference, or me making some other random mistake.