access samba share from within blender

hi everybody

i’ve got this small problem in ubuntu linux

since i’m used to keep my project on a fileserver, in a directory shared via samba, i’d like to access the directory from within the blender file requesters, but i can’t

i’ve tried with “smb://…” but no result

anybody can help?

thank you in advance

Just taking some shots in the dark here…

My first thought was that, at least in KDE, addressing a samba share only works with a single slash. That is…


smb:/

not –

smb://

Of course, I don’t know if that’s different in gnome, but I’ll assume you know what you’re doing.

Instead, I wonder if it might be possible to softlink the file you’re after.

ln -s smb:/192.168.blah.blah/sharedfolder/original_file local_file_name

I’ve never tried softlinking something on an smb share, and I have no clue if it’d work, but it sounds like it’s worth a try. Failing that, I’d just copy the file to a local directory. I know that’s not what you’re looking for, but sometimes it’s better to settle for something that works over something ideal. :slight_smile:

Best of luck!

You’ll have to mount the samba share at startup.
“mount samba share” google …

So blender will see it in /media or where you told it to mount .