Action Actuator playback bug in 2.5 to 2.63

This is kinda of a serious bug, and it totally breaks my games completely.
I just want to bring attention to this.

This bug exists in 2.5x through 2.6x

Actions with a Priority higher than 0, don’t revert back to the first frame when reactivated.

Action actuator using “Play” playback type usually allows a action to restart at (designated frame) if reactivated during playback.

But this only works correctly if the Actuator uses “Priority 0”

Compare the 2.49 file (correct behavior)
Action Actuator correct playback 2.49.blend (155 KB)

with the one made in 2.5 (bug)
Action Actuator high priority breaks playback 2.5.blend (372 KB)

Start Game, And use the “spacebar” to Play the animation.
Now press the “spacebar” again to restart the animation mid playback.
Only the Red cube restarts properly (Priority 0), while the Blue cube continues playback (Priority 1)

Up to Blender 2.59 the animation ist working correct on my PC (Windows XP 32 bit).
But since Blender 2.6x the ainimation is not working correct. I think it is broken since GSoc 2011 new animation system made by Mitchell Stokes (Moguri).
Please report the bug to the Blender Game Engine bug tracker.

The problem still persists in 2.63a

Yes I did report it,

but it hasn’t been reviewed yet, (which is odd because normally it takes about a week to get a response, but it’s been longer than that.)

The new animation system seems to be nice. Unfortunately the ActionActuator seems only be upgraded on simple “Play” mode. All modes with continues running animation system have issues. I think the ActionActuator should be reviewed.

Yeah the new options available are amazing. :slight_smile:

I just wish that “Play” mode would restart at frame 1 whenever it fires. (I need that function a lot).
Because right now, it will only do that if the priority is 0 (and since use many different values, almost none of my action restart “Play” properly).


the Priority value shouldn’t have any affect on Playback. (i.e preventing the animation from restarting)