Action Editor not showing in 3D view

I made a simple animation in the action editor where I have my character sit up and look around, it worked fine until I saved, closed, and reopened the file. Now the key frames are still present in the action editor just the way they were, but when I play the animation nothing changes, the character does not move at all. Even if I try making a new animation I key frame the loc and rot of every bone and the diamonds appear in the action editor as key frames, but once I move off of that frame it will not animate. Hope I explained that correctly. Thanks for the help.

Hmm, not really sure about this, nothing pops to mind right away. Could you post the .blend file so I could take a look?


Here is the file, the toothbrush should be laying down and then sit up and look around.


toothbrush animation help.blend (431 KB)

ok, had a look at your file and I will admit, you have me stumped. In the action editor for both the ‘sit up’ and ‘action.001’ you have keyframes set for Bone.005, Bone.006, and Bone.007. When I select your armature in the 3d window and switch to pose mode, I found your bones are named with just numbers starting at 1 for the bottom bone and ending with 16 as the top bone. I cannot locate the bones named in the action editor.

Now the walk action has all 16 bones keyed as they should be. I played around with that action a bit, advanced 10 frames and rotated a bone and keyed it, advanced another 10 frames and rotated a bone and keyed it. When I move the current frame around using the left and right arrow cursor keys, the mesh lags behind the armature. So I am thinking what about weight painting? When in pose mode, when I select a bone, the shift-select the mesh to check the weight painting, I can’t select the mesh. Not sure why.

In the outliner window (not that I’m good at understanding that window) there are 2 cubes. Cube.008 and Cube.009. Cube.009 has an armature modifier and an armature for it. Cube.008 I finally found on the top right most layer in the 3d window layers buttons. I have saved the file with the action I worked on showing the lag, just right arrow to view the lag in the mesh following the armature, and it also shows the additional cube object.

I’m not sure that the mesh has had the armature applied to it correctly. I’m not sure what the bones that are keyed in the ‘sit up’ action are. And really, I’m not sure that I can help you. I might be totally wrong here, and unsure how you animated the toothbrush, but I just don’t understand your file. Please check out the file I attached and how the mesh doesn’t follow the armature 100%.

One thing I am sure of is this: How do you know the toothbrush was invented in west virgina? Because if it was invented anywhere else, if would be called a teethbrush. :evilgrin:



toothbrush animation help-2.blend (428 KB)

That is strange how it lags behind, I never had that happen before. Could the problem be that I parented the armature to the brush? Do you know of a good tutorial on how to use the NLA editor or animating with armatures in general? Oh and lol at your West Virginia joke and thanks for the help.

The armature needs to be parented to the mesh and weight painted. I’m not sure about your set up… I do know of one good tutorial that I still look back on from time to time

I’ll ask someone else to take a look at your blend…

Heck, that’s one messed up file.

Firstly, a few housekeeping things for your file (and hopefully for future ones too):

  1. What you want to do is to parent the toothbrush mesh to the armature, not the armature to the mesh. That is, when you’ve just created your mesh and an armature, FIRST select the mesh, THEN select the armature, and press ctrl-p (choosing Armature -> ‘Bone Heat’ from the menus which pop up).
  2. Related to 1), probably due to the mistakes you made when trying to set this up, is the fact that you should avoid having ‘cyclic dependencies’ between any objects or between bones. That is, do not set an armature modifier on a cube, with the modifier using the armature, but then parent the armature to the cube. You’ll get lagging issues all over. To make sure you haven’t got any of these issues, tab in/out of editmode for your armature
  3. Make sure that you’ve cleared all object-level rotations/scaling from the meshes and armatures before you start performing step 1. Not doing this step will cause you grief in the long run, as various tools go beserk or give weird results.
  4. Do not apply subsurf modifier on your mesh. Keep the subsurf modifier turned on for the mesh, since having such dense geometry will slow down your viewport as you work.

Hopefully these will be a good starting point :slight_smile:

hey scott_s_06,

I thought I would clean up your toothbrush rig a bit, to give you a frame of reference here because it’s hard to talk you through all the little details going haywire in the file (everything Aligorith said and then some… like keyframes on your toothbrush mesh?) I appended the rigged objects into a new file and cleaned them up there.

Note, as Aligorith mentioned:

  • The mesh and armature object have no rotations and a scale of 1 (and their locations are also 0 because the centers are at world 0 - not necessary but something I like to do :))
  • The handle and bristle meshes have both been heat weighted (parented) to the armature. The armature has not been parented to anything.

This rig can now be appended or linked into your file. The animation you have will need to be re-done. In the future remember to finish your rigging completely before beginning animation (I’m guessing that’s why you have an action with names of bones that don’t exist - you changed the armature after the animation was made).


toothbrush_clean.blend (447 KB)

Wow I can’t thank you guys enough for this! This is my first try at animating with bones and I did not know exactly what to do. I new I had seen that tutorial before, but for the love of google I could not find it. This whole idea of animating a toothbrush is part of my computer graphics class in school, but everyone else is using Lightwave and I can’t wait to show them what Blender can do. Also just thought I would post a picture of the bathroom that I made for the scene, its rendered with Lux render which I sadly cant use for the animation. Thanks again for the help, I could not have gotten any further without it!