Action Logic

I have an object I would like to animate in the BGE. I made the action. Made an “always” brick an “and” brick and an “action brick”.I linked them all together. I typed in the name of my action and the frame info. When I start the game the object just sits there. What am I doing wrong?

  1. you have to use actions with armatures
  2. check pulse mode in always actuator (TRue level triggering)
  3. insert first and last key correctly in action actuator
  4. maybe switch to LOOP to see action constantly for a while

Okay, so I switched the pulse mode to positive and it still just mocks me. My action works fine in animation but not in BGE logic. Is there maybe a video tutorial so I can watch step by step?

You dont’ need true pulse, as the animation will stop when it receives a false pulse. The always sensor with default settings does not send a false pulse. Anyway, it doesn’t matter in your situation.

You have to make sure:

  1. the skin object is parented to the armature object (ctrl+p -> armature)
  2. the skin vertices have vertex groups assigned matching the names of the bones.

As far as I know envelopes are not supported in BGE. You better switch off the “envelopes” in Deform options of the Armature panel.

I hope this helps

Thanks for the suggestions. I tried all of them and a few other things too. Still just sits there on frame one though.:mad:

Maybe you show us your blend.

Here’s a blend. The action still doesn’t play in the game only sits on frame 1.


Sticks.blend (180 KB)

Oh god, I feel your pain. I had the exactly same problem a couple of months ago when I was starting on the BGE. Took me days of frustration to figure it out. What happens in that armature modifiers doesn’t really work on the BGE. You have to use the old style virtual modifiers. There is no info about it anywhere on the docs.

Do this:

  • select the Cube object
  • remove all armature modifiers on the F9 panel
  • shift right click the armature to select it as well.
  • CTRL+P to parent, choose “Armature” then “Don’t create groups” (you already created them)

Then it works. I’m uploading the working blend file.


sticks1.blend (179 KB)