add Object bug??

Hello, i think there is a add Object bug.
when i use the add object actuator the added object is not in the same x and y axes as the object that adds the object. It is werd, becaus it somethimes adds the object in the right direction, and if you move the player abit to the left it adds the object all the way to the left :x .
here is some screens about the bug

I dont think it is me that does something wrong, i think there is a bug

Ye it’s true, I ahd that sometimes too. I tought I fixed it by having an empty on fron of the gun. And instead of spawing those objects from the mesh I add them on the empty. Then parent empty to the gun and using that I fixed it, I think.

One time I had the same setup with the empty and so on, but saving my blend and testing it caused that same bug. When I reopen the file it was there too. Afther a while I redit my test and it was gone, the strange thing is that the test made from cratch (2nd one) had the same stup as the first one. :-?

The object that adds the other object is parrented to another object that rotates. And for some reason when i make the parrent(the object that arent parrented to annything ) add an object blender Stops, i get this error thingy :x .

I guess this will be fixed in the next version, Dosent look like annyone here knows how to fix it :frowning:

i had the same problem, but i fixed it somehow,…i can’t remember how though! maybe try doing a ctrl A on both the object and the gun.