Add tree add-on problen

I start Blender with the default scene, and delete the cube. Then I can add a tree, and before making any changes, there is a tool panel with several options. There is a drop-down box labeled “shape”, and in the tutorials I’ve watched, they do show it being used to create a general shape for the tree. But for some reason, mine is grayed out. I can click it to see the different shapes, but they are all grayed out so it does no good to click on them. If I click some of the presets (lower part of the same panel), such as “willow”, those work, and the shape is changed in the shape box. But I can’t change using the “shape” menu.

Could be it is because presets are not allowed to execute (these are python files in \add_curve_sapling\presets).

I’m not sure exactly what you are referring to, but I know that in the past it has worked. But this is the first time I’ve tried it since the latest Blender version (2.77a)

No problems here on quite a fresh build of 2.77
What was the Blender’s version it would work for you?

I can’t be sure but it most likely was the last one before 2.77a. I always check for the latest versions. Maybe 2.76??

Somewhere around 2.76 auto script execution was disabled as a security measure - User Prefs, File ->Auto Run Python Scripts. This should not be the cause; even without the checkmark Sapling works (and this would disable scripts set to Auto run upon opening .blend file in a first place, not to disable one UI element).

One can explicitly set UI element to disabled state by python itself: something.enabled = False, in this case there should be the word “enabled” to be found in the code. This is also not the case - Sapling parts do not contain this (or, in the version i have here, at least).

I’ve run out of ideas but you could try downloading Blender’s pack, unpack in a separate folder and try to run it.
After you unpack blender,inside, in folder named ‘2.77’ create another, named ‘config’. Then run Blender from folder above 2.77, go to User Preferences and set File, Scripts folder path to this instance of Blender (\folder_where_you_unpacked\2.77\scripts). This will insure there are no settings pointing to your other installations (and another Sapling script somewhere).

Edit: Thread turns out to be not related to Modelling, as it seems…Needs to be moved likely.

What happens when you add a primitive: Are the options for that greyed out, too?
If so, you will likely have to enable “Global Undo” under User Preferences > Editing.

Exactly, Global Undo. Guess, that’s the reason.
Minute ago i was looking at the error in Bsurfaces where after the surface is added, primitives added after can not be adjusted.

Edit: Then again if Global Undo is unchecked all options for Sapling are disabled. There is no way to edit anything but OP mentions he is able to use most of the ui except Shape.

Nope. Primitives are fine. And for the “Add Curve>Add Tree” it is ONLY the shape option that is grayed out. The rest (Geometry, Bevel, Vector and all the ones below “Shape” are all OK.

I did try enabling AutoRun scripts, but it did not fix the issue.

The old script used to do that , greyed out until you added more branches.
The new script version should be 0.3.2 , check your script version.

I have version 0.2.6. I didn’t see a newer version in the extensions catalog. I checked the online resources and it took me to the add-ons for Blender 2.6, but nothing later. That add-on version said it was 0,2.

Correct version should be included in any recent blender’s pack from builder, guess the question is solved.
Could not imagine this was still the old version…

Well I can try to reinstall Blender 2.77a (Still the latest official version) and see if it changes anything. But I don’t know why the new version of the “sapling” script wouldn’t have been included when I installed this version of Blender a few months ago (April).

I uninstalled Blender and downloaded a complete new .msi file, and reinstalled 2.77a, but it’s just the same. Same version (0.2.6) of the sapling add-on. One thing I noticed though, all my user preferences and my startup file were the same as I had them before the new install. I know I chose NOT to keep old files at the installation screen, so I don’t know if that makes a difference.

Here is what’s done with Sapling.

Here you can download each file if you click on the file name and choose ‘raw’ from above menu, then Save Page As from browser. Replace files you have.

Can’t comment on msi though.

Thanks for your help. I really appreciate it. I got it to work, and when I have time I will copy some of the new tree presets, but for now it’s working. I just don’t understand why it didn’t load with the new Blender 2.77a install.