Adding a face to side of object changes shading on top

As you can see I’ve got 2 identical meshes.

But in the next screenshot as soon as I fill in a area on the rightmost mesh(near the cursor) I get shading on the top as seen below. They are filled with quads and not triangles.

Even more apparent in the next screenshot, same mesh’s viewed from another angle. The dark shading on the left mesh is caused my adding a face to the side of it.

So is there anyway to avoid this unwanted shading on the top face. The only way i can seem to do it- and it’s kind of a bodge - is to place a face which is not connected to the rest of the mesh instead of filling the existing vertices.

shading_test.blend (554 KB)


You’re using smooth shading on a mostly flat object.
Smooth shading is intended to - well - smooth the transition between neighbouring faces, in your case between the top and bottom faces and the orthogonal side piece. Since top and bottom are basically just two large polygons, this smoothing attempt will affect a large area of your mesh and will look correspondingly weird.

Your options:

  1. Flat shading OR
  2. Edge Split modifier OR
  3. Autosmooth (Object tab) with a small angle, e. g. 30°.

as IkariShinji said, you are using smooth shading, it is very useful but you have to adjust your mesh first, so you dont get that bad shading effects, he said one way to fix but you can also use support loops, in the image will be a better explanation

I forgot one image, but if you do use that first method be sure to work with a good topology otherwise it can create a big mess lol

Thanks guys, I think I tried smooth shading before I posted this but ill give it another go.

EDIT : Just changed it from smooth to flat shading & it worked fine without changing anything else, I could have sworn I’d already tried that.

Thanks for your help.