Adding new mesh - not showing up

Hello guys,

Blender 2.48a

Have been working on my blender file for couple of days by modeling one object.
This part is finished, now I wanted to add another object to the same file and continue to model that part. However I’ve ran into the following problem:

From object mode: [spacebar] ADD -> MESH -> here i choose the mesh i want, particularly in this case it is Sculpt Mesh, however tried with simple plane as well - all the same - mesh object is simply not showing up.

I cannot select it since it is not visible for some reason. However I see its properties being displayed, while i havent switched to my only one visible object. No resizing, no moving cannot be done here too. Also tried to hide unhide objects … same result - i see only the object i was modeling before.

Any help would be greatly appreciated.

Thanks

somehow sorted it out by switching and clicking here and there in the outliner view… but still - didnt get what went wrong before, and why now i finally am able to add the mesh.