Adding Sound Effects

I have rendered an animation into an image sequence and combined it with a sound strip in the VSE. However, when I try to render the final animation on my Mac OSX 10.5.8 I end up with only the sound and a solid black image. This is the format I am using:

Edit: Here’s a link to the image:

When I set the output to just Quicktime it renders only the image without the sound. The sound effect is a .wav format.

We can’t see the image you uploaded so we can’t see your settings.
Can you set the output type to Quicktime and then change the audio encoding options? You know there’s a separate spot in Blender to choose your audio encoding options and by default Blender is set to not render any audio, right?

This issue has been discussed a lot. If you search this forum you should be able to find many answers. Long story short, the sequencer might render out any video format but the audio might not work for several reasons. Using typical resolutions might help.

I can set the output to Quicktime but I can’t find where the audio encoding options are. They only show up when I set the output to H.264 and set the format to Quicktime, but then only the audio works.

I have the exact same problem the resulting render is totally black with no audio. Let’s hope we find a solution to this one. :slight_smile:

Well, I do get audio, but the render is completely black.

Hmm. from some of the threads I’ve been reading it sounds like a video card issue. Not what I was hoping for but what video cards are you using?

I don’t really think this is a graphics card issue. Ffmpeg will most likely render out any container format with (almost) any combination of video and audio codecs. What I would suggest is rendering out to a conventional container/codec combination for quicktime.

Using the preset dimensions often helps the encoding process. Even if only for a test.

blendercomp, thanks. trying a number of combinations. I think my version of QTPro is outdated too so that’s most likely why the .mov files won’t open using QT but I have been able to open them with other viewers. :slight_smile:

3pointEdit, thanks. I opened up an old file and the movie was visible in the VSE (not sure why though).:confused: but now other problems like type not showing up in VSE.

  1. Anyone have any idea why my type shows up in “Viewer Node Preview” (right) but not in “VSE”? Really frustrating.
    (I also tried adding the type to the VSE as an image above the movie but I don’t think the VSE supports transparent .png because the type was white on a totally black background and the movie wasn’t visible)

Does anyone know how to get type to show up in the VSE?

Umm, not sure how you are trying to do that. But why not make a second scene with the nodes effect, then add that scene as a Scene Strip to your master VSE edit timeline. Alternately you could render the key effect out and import it as a strip. Or you could add the keyed image as an alpha over strip in the VSE to go on top of the vision strip.

Hi, thanks for the reply. Not sure what you mean by adding a scene as a scene strip but sounds like an interesting approach.

I am just using the composite nodes to add a .png text image to the scene. I then imported a .mov file and I want to composite them together. Easily done in AE but obviously a chore in Blender. This should be easily accomplished but for some unknown reason the text is not above the .mov file in the VSE. Hmm.

You can’t bring compositor output into vse. It has to come from a scene as the compositor is the last step in the render chain.

Hi, no I didn’t use any compositor output in VSE. I only use a .mov file and then a transparent .png image for the text.

Why does the transparent .png (text) not show “on top” of the .mov file in the VSE?

Like 3point I’m kinda puzzled by this question too. The png does not show up in the VSE image preview because…it is not there. From your snapshot all I see is two strips, image and audio. It appears that there’s no image strip containing the text on the top of the other two strips. As 3point mentioned, that would also need an alpha over effect strip to get it to show up on the top of all other stuff.

I cannot really understand how the compositor is related to this question though. Did you manage to do this in the compositor and you’re simply wondering how to achieve it in the VSE?

Btw, as the current topic of the thread is not even remotely related to the original thread title, it may be a good idea to start a new thread. (just a suggestion)

Ok, sorry for the confusion but I do have an “alpha over” and an “image strip” so any ideas why is the type not showing up on top of the .mov file? It must be something simple I am missing.


The short answer is that scaling of the compositor works differently than scaling in the sequencer. You could thread the output of the render layer node to a scale node and set the image dimensions to absolute before the rest of the noodle (i.e. the color balance node). Then of course you should make sure that the VSE project dimensions match the absolute image dimensions of the former step.

However, this is much easier to to in the VSE using a text image with alpha data. Like I suggested above put that image on the top of the other strips and use an alpha over effect strip. It’s that simple really if you don’t want to do anything more complicated with it. If you do then the compositor is your best friend.

Thanks 3pointEdit and blendercomp for your patience. I finally got the type to sit on top of the movie in the VSE using the alpha over.

Paint guy the one thing missing in the screeny is the .png strip properties. It’s hard to know what you have ticked (or not) with out it.

Ok so I had a go too. I made a Keyed graphic and remembered to set output properties to RGBA (in the save path panel). I brought it in to compositor fine.

I brought them into VSE and tried Alpha Over first. The result below is a sort of ADD effect, don’t know why.

Then I moved the keyed image below the background, set it’s property to REPLACE. And then I set the background image to Alpha Under. This time it worked as a straight key. Odd isn’t it?