[Addon] Boundary aligned remesh


(Jeacom) #1

I saw people sharing stuff about triangle meshes, cloth simulation, so I had to give my small contribution.

I made this addon last night.

The algorithm is quite simple and very similar to the one used on Toporake, feel free to use and adapt the code as you want.


boundary_alinged_remesh.py (6.8 KB)


[Addon] SculpTkt - a toolkit for sculptors ($)
List of addons that work with 2.8
(Lopo Isaac) #2

Wow! Thanks for sharing this! Very useful for sculpting :slight_smile:


(Dito) #3

This is awesome!
Thank you very much Jeacom.


(wilBr) #4

wow … thanks…
very useful
:grinning:


(NewVisitor) #5

Great for Fonts or imported SVGs.
No Rendering Artefacts.
Now there would only have to be one trick to use the Bevel Modifier (Bevel-Shader is too inflexible and slow)


Tris to quads
(Mystical) #6

Looks like in the more recent versions of Blender 2.8 the add-on has broke:


(Jeacom) #7

No, its not broken, make sure your model is open, This addon only works for models with boundary not solid meshes.
Seems like I forgot to trow a warning message instead if allowing a error exception :sweat_smile:.


(Mystical) #8

That did the trick, was trying to use it on a solid one. The error had always made me think it was partially not working at times. Thanks for clearing that up.


#9

It does seem broken to me @Jeacom, it gives me this error when enabling it in the latest 2.80 build. Anything I can do myself?

edit: info: W7 x64, blender-2.80-388ff003e28b-win64


(Dito) #10

Darkfibre is right, I get the same error as well.


(Jeacom) #11

Humm It might be some new build’s problem.


(Jeacom) #12

Its fixed now.

Seems like they renamed VIEW3D_MT_object_specials to VIEW3D_MT_object_context_menu

boundary_alinged_remesh.py (6.8 KB)


(Dito) #13

Hi Jeacom,

super fast fix, many thanks.


#14

Yep it works now. Thanks for the quick fix!


(uruburei) #15

I need to try it.