[Addon] | Crowdrender - distributed rendering - what features do you want?

Hi James,

Last night I couldn’t resist to test some more on my unactive computers while my primary rig was doing the heavy workload on my deadline.

Tested with a simpler sample scene from www.chocofur.com and everything worked. Mixed PC/MAC CPU/GPU after packing the textures. What was a releave. Final result assembled on the server side without gaps or magenta coloring.

To be honest I also toke the time to read your documentation. What I didn’t a few days back when I was busy getting to download the addon.

With my own project I am having trouble packing my textures. When I use the Blender function to pack it Blender cannot find older image files that aren’t used on models. Hope to solve this by cleaning out my messy project.

The real problem with my project is the use of textures with “image sequences”. I presume Blender cannot pack these (37) images. They only get loaded when the corresponding frame renders in the animation. That was my solution to automatic render my 37 hires stills.

But like you said let’s dig deeper soonish.


1 Like

Hey Bart, glad it worked out with your new test scene. And yes, packing 37 sequenced images is not something I think most users do regularly, but I am sure with a bit of ingenuity it can be made to work

One solution is to put the images on a NAS or shared folder on the network and re-link your project to use the shared location. This way, they don’t have to be packed and will be available at render time for a small performance penalty (depending on the size of the images and of course your network speed and effective bandwidth).

If this is something you haven’t tried yet, it might be a nice way to do it as there is little configuration effort other than hosting the files somewhere that each computer can get them.

The complication with a shared network location tends to arise with different operating systems. If you host the files on a windows machine, then you can find it a pain to get linux or mac computers to access the files. But that might be outdated information now, I honestly haven’t tried this in a while.

Will try that shared storage setup, when we find the time.


HI James,

One thing I experienced when testing CR last week was that my node setups disappeared and I was unable to edit them.

It was a bit scary at first but I could fix this when changing the render engine back and forth. Meaning switching from Cycles to Eevee and back to Cycles. After that I was able to work and tweak my material node settings again.

Don’t know I this is a Mac OS bug or a general one.


1 Like

Hi Bart, I think I know what you’re talking about. If you change the render engine you see your shading nodes disappear, is that right?

Or are you referring to the render nodes disappearing?

Clarification will help!

Shading nodes that is.


Ok, I think I know what this could be, Crowdrender uses a ‘hidden’ render engine to render, you can see it in the render engines list as a blank entry. If this gets selected by accident, you’ll see your shader nodes disappear because CR doesn’t have any support for shader nodes. As a result, when the CR engine is selected, all the shader nodes will disappear.

The CR engine is only used by our add-on after you press render still or render animation. The addon will automatically switch to it to render, then switch back to your previously selected choice of render engine again once the render is done.

In certain situations the engine may not switch back, and you’ll see the same thing, no shader nodes. You found out by experimenting how to fix this, just switch the engine back to cycles or eevee.

Hope this helps?


Okay that explains the weird behaviour. Not switching back to the previous render engine was probably caused by premature escaping the render process of CR. Because I was too impatient when testing CR.

Although not a big issue, maybe a switch to the previous engine after abording a renderprocess would be nice in the future. I know a was rather in panic because I thought my scene was corrupt and unusable after using CR.

Still hoping to really testdrive VR in a few days.


Hi Bart,

It is supposed to switch when you cancel, or when the render finishes, if its not consistently doing that, then we have ourselves a bug to fix!

Honestly though, we’re open and actively looking for a better solution. The only trick is we don’t want to have to duplicate the shader node solution already within cycles. We’d much rather you just develop your scene as normal and then just render faster! That is why we designed the system this way, it was the lesser of two evils, the evil of either having to replicate cycles in our addon completely, or have the current solution where it can cause confusion sometimes if the engine doesn’t switch back.

What do you think? How would you like Crowdrender to work when there is a choice of render engines?

Hey James,

I think you all are doing a great job. I am happy with the system as it is. Now that I know the method of getting the node setup back. Maybe my way of tweaking and altering the scene and wanting to test render is a bit oldfashioned now that we have a really good viewport render with cycles and eevee.

Keep up the good work fellas,

1 Like


I’ve found that when crowdrender addon is active the autosave function no longer works :scream:

0.17 CD version and linux 2.80 blender from 11 july.

Hi Botoni, uh oh, ok thanks for the heads up, we’ll take a look at that, cheers for posting, that helps a lot!