[Addon] Image sequence import as planes


(vicentecarro) #1

Hi,

This addon is an extension/fork of the Import ‘Image as Planes’ one. It allows to import an image series/sequence as an animation, placing all of them in the same place and animating the visibility and render-ability of each one.
You have 2 new options in the panel:
Animate and Animation duration.
In order to activate the new feature you need to activate the “Animate” checkbox. Note that “align” option will be set off automatically but if, for some reason, you need it you still can activate it.
Animation duration is used to specify the number of frames a picture will be shown.

And a simple howto.

I needed this feature for internal usage but I decided to share it, maybe it can be of help for someone else.

Planned features:
-Add empty parent per picture so you have a simple way to transform them.
-Add a master empty to move all the pictures at the same time.
-Set duration scene. To automatically set the end of the scene to match the length of the animation.
-Set viewport. Basically activate GLSL and Material modes.
-Add camera. Adds a new camera perfectly aligned with the new pictures.
-Decide if this is going to be a fork or just an extension of the original script. Probably just an extension.

Ideas?

Attachments

io_import_image_sequence_as_planes.py.zip (7.45 KB)


(vicentecarro) #2

Oh I forgot, the pictures used in the video are not mine and they have copyright.


(bned) #3

Great add-on! Thank you for sharing! =)


(vicentecarro) #4

A bit late but thank you, bned.


(marietto) #5

Hello,maybe I come here late,but this addon can be useful in my situation and then I tried it. Anyway,it didn’t work. I recorded a video to show what happens. You can find it here :


(vicentecarro) #6

Sorry for the super late answer. I wasn’t really maintaining this script but let’s see if I can help, if I’m not too late for that
So I can see on my end that the script won’t work with Cycles and you are using Cycles in your scene. Can you try with Blender Internal just to be sure that’s not the problem?

Also it was not designed to transform the planes after they are placed. However you could copy the transform from the one that you already placed as you want into the other ones. It’s quite possible that the planes are being animated but in their original location so they are impossible to see from the front view.

Let me know your findings.

Can you see if you get any messages in the terminal(if you are in windows and it’s hidden open it with Windows/Toggle system console)? Maybe in the Info tab(you need to extend downwards the very top tab that says “File Render Window Help” and you will be able to see some hidden messages.


(vicentecarro) #7

By the way I just added a public repository with the script in Github, just in case someone wants to fork it or something.


(marietto) #8

Hello,I’m using your addon. I would like to know if you can add two more features :

  1. a button to enable / disable the option “restrict viewport visibility” for ALL the image mapped planes

  2. another button to enable / disable the option “restrict rendering” for ALL the image mapped planes

because as soon as I select all the images,they are mapped on a series of planes that are not oriented as I want. usually I need to rotate them to 90 degrees,but to do this I need to select all the planes in a single click. BUT to do this,I need to make every/each plane visible and rendered… to do this I need to select the planes one by one but it takes times.

thanks.