[Addon] Jet Fluids

Jet Fluids is a fluid simulation addon:

This addon uses the framework:

If you are interested in this addon, you can help develop it (you can write a pull request).

Or if you find an error, you can create an issue.

Warning: addon is at an early stage of development.

5 Likes

The addon has been updated to version “Demo 0.0.5”:

Key features of Demo version 0.0.5:

  • Support FLIP, PIC, APIC hybrid liquid solvers
  • Building a mesh over fluid particles
  • Building a mesh from arbitrary particles and arbitrary vertices
  • Viscosity effect support
  • Emitter and obstacle support
  • It is possible to indicate the color of the created particles
  • You can convey the color of the particles to the fluid mesh (there are problems)
  • Integration in blender 2.81
  • It is possible to convert liquid particles into a standard blender particle system

The author of the fluid engine: Doyub Kim (https://github.com/doyubkim/fluid-engine-dev)
Creator Jet Fluids Addon: Pavel_Blend

PS: I am not a professional programmer and I do not have much experience, so some errors and inconveniences are possible.

If you have comments about the code or about the add-on in general, then write to this topic or on github.

Unfortunately, there is no documentation.

I will begin to write documentation when the addon accepts a more stable state.

3 Likes

Looks so cool !

I’ll test it soon!

1 Like

Hi~
I can’t install this add-on, and I’ve tried to install and copy paste into the blender script folder, and both aren’t work.

here is a screenshot


any idea?

It installs and activates fine here (Blender 2.81a, W10).

For a test I made a simple plane emitter, cube domain and plane collider. Then simulated.
But when I played back the sim, it got stuck on 2nd frame.
So I did reset and wanted to bake again (with less particles & lesser resolution) but then it gave me an error:

Traceback (most recent call last):
  File "C:\Users\X\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\jet_fluids\bake_particles.py", line 358, in invoke
    self.execute(context)
  File "C:\Users\X\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\jet_fluids\bake_particles.py", line 283, in execute
    self.simulate(offset=frame_start, particles_colors=[])
  File "C:\Users\X\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\jet_fluids\bake_particles.py", line 66, in simulate
    color = emitter.data.vertex_colors[0].data[loop_index].color
IndexError: bpy_prop_collection[index]: index 0 out of range, size 0

location: <unknown location>:-1

PS
Error is caused by JetFluid Color: Use Color enabled.

Would be good, if you had exemplary scene files available…

Hi~
I can’t install this add-on, and I’ve tried to install and copy paste into the blender script folder, and both aren’t work.

It was necessary to download the release from here:

The file with the addon is called jet_fluids_demo_0_0_5.zip
Download this zip file and specify it in the blender settings using the Install button.

I forgot to add a Vertex Colors check on the mesh. Add vertex colors to all emitters. I will fix this error later.

I recorded a video with a workflow:

2 Likes

The jet fluids addon now works in blender 3.2:

3 Likes