[Addon] UvSquares v1.9 (updated - 2.80 and multi island support)

Hi, Radivarig!
First of all, thanks a lot for this great mod! Is a must for me, and IMO should be included by default in Blender.
I found that under circumstances shown in the screenshot it may not work properly. As you can see is the same shape. In the first the cuts in the circular face make that “to grid by shape” doesn’t work. In the other, without those edges or with the face removed, all work o.k.

Seems the addon consider the adjacent faces, even if they are on other uv islands, and even if they are not selected to be shown in the uv layout.


Is there a download link for Blender installation (not as a script) please? I see there are 2 scripts to download and am frustrated how to install both.

Click the big green button at this link, and choose download.

Once downloaded, remove the ‘-master’ in the name, and you should be able to install it as any other add on from the blender user preferences add ons window.

1 Like

i wish someone update the addon for 2.8

1 Like

See if this works. There’s one line of code I had to comment out ,cause it looks like it got removed from the API in 2.8. Not 100% sure what it did exactly ,but it still seems to work.

UvSquares_2_80.zip (26.5 KB)


thank you for the update

Thank you for the great addon!
It worked fine for me in 2.80 at first me but suddenly stopped working some time ago.

Am I doing something wrong?

Hi, try this one UvSquares_v1.8.2_upgrade7-80_2.zip (15.9 KB)

2.80 API is still changing so there might be more, I fix them as they get reported.


Thank you! Working fine again :smiley:

Add me to the list of folks asking for the update for 2.8 if you’re still working on this.

Lovely addon- can’t believe this feature isn’t native yet!

1 Like

Not sure if this is still working. It install without any issues, but I can’t get it to work. Is there a step I’m missing?! Can anyone help me out, please? Thank you!

hey guys,

is it somehow possible to align uvs squarish that are not quad only?

cheers chris

1 Like

Works fine with the latest build…
Thanks for the awesome addon!!

  1. select quad fragment
  2. square grid by shape
  3. pin
  4. select rest of uv island
  5. regular unwrap

Hello everyone,

I have been trying to install this addon into 2.8 but it doesnt seem to work. if I use the 1.5 master version on the github I can install but, it says in the addons ‘needs upgrade to 2.8x’. I have come across this forum and tried the uvsquares_v1.8.2 and if I install that one, I dont see the addon in the options to activate. Am I doing this wrong? I have also tried to install the 1.5 github one then the 1.8.2 but same thing happens I just dont see the addon in the list to activate. Any help would be greatly appreciated


Having the same issue. I hope it can get fixed for 2.8!

Hi, any chance of an update for the latest 2.80 version? The add-on will not install correctly. It says “update to 2.8x required”.

UV Squares Blender 2.8 code fix/workaround

Download the latest release from github for UV Squares

Then update the


file in Visual Studio Code or Notepad

To remove the blender 2.8 Upgrade warning change the bl_info section from:

bl_info = {
“name”: “UV Squares”,
“description”: “UV Editor tool for reshaping selection to grid.”,
“author”: “Reslav Hollos”,
“version”: (1, 5, 0),
“blender”: (2, 71, 0),
“category”: “Mesh”,
#“location”: “UV Image Editor > UVs > UVs to grid of squares”,
#“warning”: “”,
“wiki_url”: “http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/UV/Uv_Squares


bl_info = {
“name”: “UV Squares”,
“description”: “UV Editor tool for reshaping selection to grid.”,
“author”: “Reslav Hollos”,
“version”: (1, 5, 0),
“blender”: (2, 80, 0),
“category”: “Mesh”,
#“location”: “UV Image Editor > UVs > UVs to grid of squares”,
#“warning”: “”,
“wiki_url”: “http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/UV/Uv_Squares

Note that only the property of BLENDER has changed in the file to “blender”: (2, 80, 0),

I also had to comment out line 52 of the code to get this working in Blender 2.8, just add a # symbol in from of this line as follows:


Reinstall the addon and it should work for what most people need.

I’m hoping this addon gets some official love when Blender comes out of Beta soon.

Check again, you’re not using the latest one, but old “master” :wink:
switch branch from “master” to “upgrade7-80_2” or simply click link below for v1.8.2

here’s under Add-ons

and in UV Editor

1 Like

Thanks for this, I completely missed that branch. I’ll clone it and give it a go. :grin: