[Addon] Wazou's Pie Menus


(wuren) #21

I have the same problem. I am using blender 2.7.1 ! Need help!


(Pitiwazou) #22

For the pie menus you need the last build.

wuren, are you on MAC Os too ?


(0rAngE) #23

I used to get that as well on the first load.
Just try enabling it a few times, it should work.


(kakachiex2) #24

@pitiwazou

  • snapping menu appear in texture paint mode
  • wen activated retopo pie menu and pres right mouse button to exit do nothing or appear the add shortcut menu
  • the cursor origin menu some function that only work in object mode give errors in edit mode so would be better if you make them inactive in edit mode or make a menus specially for object mode " suggestion "

(Pitiwazou) #25

Ok thank you, I will fix the code.

  • For the snapping menu, it’s appear in every mode in blender even without my Addon;)
  • For the cursor, the Cursor to bottom is fixed !
  • To exit a pie menu, you need to press Echap, it’s not a bug :wink:

(wuren) #26

Hello, pitiwazou, i am using blender 2.71 - win7 sp1.
I used the last build, when I enabled in User Preferences, I get an error at line 1496 in register kmi.properties.name = ‘pie.objectitmode’ ‘OperatorProperties’ AttributeError:‘OpertatorProperties’ object has no attribute ‘name’


(Pitiwazou) #27

Ok,

Tell me if it’s OK now plz :wink:


(MichelWeber) #28

Same error but line 1496 instead.


(Pitiwazou) #29

Someone alse as a problem with the Addon ?

That works perfecly on my PC, I cannot test on MAC OS :frowning:


(0rAngE) #30

Yeah, I get an error as well. Don’t remember how consistent though.
I was loading/unloading it very frequently while I was modifying it and adding stuff. I was getting errors as well. (I believe I did get the error even before I bastardized the code with my edits)

It would error out on first load, but I just keep trying. Usually it is enabled with just the second try. Never needed more than 3-4 times.

I’m on a PC win7 64

Edit:
I’m just about to give your latest build a go. I’ll report back.

Edit:
No errors on the latest version!


(MichelWeber) #31

I tried it on a Win 7 machine - same error.


(Pitiwazou) #32

Weird, no error on my last version, I checked the officiall pies and I have the same code for the keymap.


(0rAngE) #33

MichelWeber, have you tried Loading Factory Settings, then anabling it? In case some of your custom prefs are causing it.


(MichelWeber) #34

I tried loading factory settings. Then installed the pie menu - when I enabled it, same error.


(Pitiwazou) #35

I will Try on my second PC and on linux, but I have no bug here.
have you activated the official pie menus ?

You don’t need it.


(MichelWeber) #36

I don’t believe so. Not sure where/how to do that.
I attached an image with the error.


(0rAngE) #37

Preferences > Addons > User Interface: Pie Menus Official

Edit:
If you don’t have that in the Addons, grab the latest blender build from:
https://builder.blender.org/download/


(Pitiwazou) #38

I’m a newbie in python, but, it seems that your blender version don’t know the “WM_QT_call_menu_pie”.
Are you shure that your version can use pie ?
Have you the official pie in this build and it’s working good if it is ?


(MichelWeber) #39

That must be it - I need to get a newer build - I had no idea. I’ll try that and report back at a later time. Thank you.


(Pitiwazou) #40

Little Update on the code with the proportionnal Edit in Object and Edit mode.
And some changes for Viewnunmpad pie and Select mode Pie !

Thx to OrAngE for his help ^^