[Addons] EWOCprojects tools collection


(kakachiex2) #21

really, really thanks paleajed


(Spirou4D) #22

Hi Paleajed,

Your very great add-ons EWOCprojects Tools don’t run with the new Blender 2.66 RC.
If you could take a look about, this problem will disappear with the often stable 2.66 official!
Good Look…
Spirou4D from french France…


(paleajed) #23

@Spirou4D : which system/OS are you on? I just tested the tools collection on 2.66RC Linux 32bit, and the addons I tested seem to work without problem…


(dank0) #24

The tools works on Ubuntu 12.10 64bit 2.66RC


(heavywaters) #25

I have a problem with the CreaPrim Version 0.3.9 script.
I am on Windows 7 64bit running Blender 2.65.9 r54101.

The add-on seems to be working fine and the generated “add mesh” script shows up in User Preferences, but is not selectable.

Any idea why?


(paleajed) #26

@heavywaters : Ill take a look tonight


(paleajed) #27

@heavywaters : sorry, but Ill need more information to tackle your problem
first start blender using the Command Prompt: cd into blenders directory, then start blender.exe
when trying to enable the add_mesh script look into the console and copy the error that pops up there here on the forum, this will give me the needed information to check whats going wrong…


(CoDEmanX) #28

i couldn’t spot a problem just by looking at the code, but wondering if this is any useful:

strlist.append("if \"bpy\" in locals():
")
    strlist.append("       import imp
")

does it actually do something? (loading the imp module)


(heavywaters) #29

Please forgive my ignorance, but I don’t understand what you mean by: “cd into blenders directory”.
Sorry, I’m not fluent with command prompt.

I had another script that could not be selected, and was told that it was usually caused by missing lines of code.
I recopied the script and replaced the old one, that fixed the problem.


(paleajed) #30

@CoDEmanX : good point you make there, to be honest I dont know what the “import imp” does, but when I first started writing addons for 2.5, I used a certain (dont remember which) addon as example, and that line was in there… so I copied it into about every addon I made since :smiley: - well it probably shouldnt be there…

@heavywaters : so,is it fixed now?


(heavywaters) #31

No, that was a fix for a different problem, tried that with this script but it had no effect.


Hope that’s the info you need.


(paleajed) #32

@heavywaters : thats exactly what I need!
So whats wrong, well, I havent provided yet for object names with spaces in the name, they give an error, try giving a name without spaces, like My_Prim…
Ill try adding auto-conversion of spaces into underscores when I have some time! (let me know if more errors pop up)


(paleajed) #33

Well, I did it straight away :eyebrowlift:.
New version of CreaPrim and also the EWOCprojects tools : spaces in names are now auto-converted into underscores and also dirty meshes with several same edges/faces will now be handled correctly.


(heavywaters) #34

Now it works perfectly.
It figures that it was something I was doing wrong, I’m just glad it was something simple.

I will give the new version a try and thanx for the help.


(dank0) #35

Those are great tools but i still miss Repeat option - F3. please please Paleajed include this basic feature in the future releases :wink:

Edit: Maybe you are wondering why I wish to have this feature? I mapped the F3 key to my mouse button and it is really fast to repeat or see list of recently used tools without touching the keyboard. this really speeds up your work-flow.


(Numarul7) #36

Ruler (grid) dont work in 2.66 gives some error i dont understand and i need it.


(paleajed) #37

@Numarul7 : fixed !


(paleajed) #38

version 0.3.3

Fixed EdgeGrow.


(Spirou4D) #39

Hi Master Paleajed,

[EWOCprojects tools]
I have this traceback with Blender 2.68a sur OS Win vista pack2:
“Traceback (most recent call last):
File “C:\Program Files\Blender Foundation\Blender\2.68\scripts\addons_extern\EWOCprojects tools\mesh_paredge.py”, line 1005, in redraw
adapt(scn, None)
File “C:\Program Files\Blender Foundation\Blender\2.68\scripts\addons_extern\EWOCprojects tools\mesh_paredge.py”, line 609, in adapt
bmesh.update_edit_mesh(mesh, destructive=True)
ValueError: The mesh must be in editmode
RNA Warning: Current value “0” matches no enum in ‘Scene’, ‘Scene’, ‘FromObject’
RNA Warning: Current value “0” matches no enum in ‘Scene’, ‘Scene’, ‘FromObject’
RNA Warning: Current value “0” matches no enum in ‘Scene’, ‘Scene’, ‘FromObject’”

and I am in editmode (edge selected) on a simple cube???

Always the same question about:

[Transpref]:
“Traceback (most recent call last):
File “C:\Program Files\Blender Foundation\Blender\2.68\scripts\addons_extern\space_view3d_transpref.py”, line 444, in redraw
transplist[position] = scn.Transp
IndexError: list assignment index out of range
RNA Warning: Current value “0” matches no enum in ‘Scene’, ‘Scene’, ‘FromObject’
RNA Warning: Current value “0” matches no enum in ‘Scene’, ‘Scene’, ‘FromObject’”

What do you think about, please?


(paleajed) #40

version 0.3.4

Fixed all this.