AddRoutes (MIDI, OSC + Blemote, a nascent Android app)

Hello, as the original author of AddOSC/AddMIDI for Blender 2.7x I have been working on a new Add-on for Blender 2.8x which covers the same functionalities but is aswell a full rewrite with many new features. This Add-on is intended to support later a few more protocols and already offers MIDI and OSC.

There is already a documentation here and a download section with a link to get it:
http://www.jpfep.net/pages/addroutes

Last month I released an Android application to compliment this Add-on, allowing to remote control Blender properties if you don’t have a dedicated hardware surface with knobs and sliders. This application called Blemote (yeah, it’s a funny name) is still very young :
http://www.jpfep.net/pages/addons/midi-osc-and-more/blemote/

The Add-on is already used by a few intrepid users and even though there are still many improvements to be done, I think it’s time to communicate a bit more about its existence.

News:
-3 April 2020 : v0.27 -> http://www.jpfep.net/addroutes-v027/
-23 March 2020: The Add-on has been renamed as AddRoutes. A new version is available. See
http://www.jpfep.net/addroutes-v026-blemote-v02/

7 Likes

Hazzah! Thanks for your great work!
I was having trouble using ‘MIDI, OSC and More’, however.
(By the way, I’m not the most tech savvy person, so this isn’t all terribly obvious to me. Please forgive me.)

  1. I install the plugin.
  2. I create a new project.
  3. I create a cube.
  4. I right click the Y rotation of the cube and click ‘Create A Realtime Route’.
  5. I expand the MIDI OSC menu.
  6. I select my ‘nanoKONTROL’ as the ‘Midi In’.
  7. ??? :confounded: ???¿

Okay… This is where I’m lost. I don’t understand the instructions beyond that.
How do I link a specific push button on my midi controller to this rotation variable I’ve routed to it?
I’ve read all the documentation you’ve supplied, but I’m still lost, cuz I’m a n00b.

Thanks to anyone who can help!

1 Like

Hi @ JPfeP I am very interested in testing this AddOSC from Blemote.
I am almost to the point of giving up OSC because I haven’t got any results -at all- with Blender.
I’ve worked with 3DsMax and Softimage in the past, using iOs and Android respectively.
But it’s 2020, and I really, really, really wish there was a way for me to plug parameters in and drive them with the phone. Is Blemote available on the android store? Does it have custom layout designs?
Can AddOSC work with TouchOSC in the phone? I´ve been using it for the longest…
Thanks

I tried to download Blemote.apk twice but says the package fails to install. I am using android 4.4.4

Yes it works with TouchOSC.

The app was build with a minimum API level = 21 which corresponds to Android 5 but I think I might try for the next version to switch to level 19 (and lower) to make the app run on Android 4.4.4…

The MIDI push button you are referring to is probably a “Continuous Controller 7bit”, so the next step is to select than kind of messages instead of the default value “Key On Number”. See the Routes tab, to edit the route created by step 4.

Thank you so much for your reply.

I guess I really need to have my hand held, here, as I’ve spent days and still can’t figure it out.

I’ve included the settings I’m using, below.
Maybe my midi isn’t routed properly??
I’m new to midi! I have Midi Ox, but I’m not sure how to use it, necessarily.
And when I open it, it says my midi controller is out of memory, unless I close Blender.

Thanks so much!

Don’t worry. I am upgrading to Android 9 next week. Just help me, please, to setup a video using Hexler’s TouchOSC in Android to run with your MOM addon. I have no clue how to map parameters there. Obviously I am testing it with a tablet on Android 8… but without a video…

If any of you other folks messing with this plugin have any insight, I haven’t figured out my issue, yet and my deadline is about to crush me :frowning: I would really appreciate any ideas. I feel like my issue is very basic, but it’s just above my head.

SOLVED
Turns out the drivers/software for my Korg NanKontrol are fussy.
I plugged in my Novation LaunchPad and the plugin worked.

Thanks for the great plugin!

Hello!

How did you find the solution? My midi controller works on other applications.

I have the same problem and I can’t get any further. I have an Oxygen 25 midi controller.

I select it, create a realtime route for the Y-position on the cube. Set to continuous controller 7…Then what? I tried everything I can’t see any movement and the documentation has no information on setting up.

Any help is appreciated!

A new version is available, and the Add-on is now called AddRoutes:
http://www.jpfep.net/addroutes-v026-blemote-v02/

@crispyastrologer: Well, for MIDI route and cc7 you need to “select” the right controller and set the route to receive. You can use the debug option to control if at least something arrives in Blender and if a route responds. It’s a little checkbox at the right of the MIDI input device.

2 Likes

Hi @JPfeP . I think this plugin is major as I am a big fan of using controllers.

ATM I want to learn to use it, in basic mode, so I want to turn my Launchpad into a Hotkeys pad. First I tried with my Launchpad, then I tried with my MPD32 so I could see the note numbers on my controller screen. None worked the way I configured it. And Windows10 is recognizing the devices plugged in the usb port.

The first error I find with AddRoutes is that when I right-click on an item, for instance the “Snap” icon, the “create a realtime route” option is grayed out, before and after configuring it all the way like in the screenshots. Or after selecting my controller and right clicking the option is grayed out, without having created a route already. I have read the documentation and have tried out a lot of different configurations and I can’t get it to work. I don’t know where my configuration fail is at.

Last week with M.O.M I got the “create a realtime route” to work, but when pressing the right note number nothing happened. I’m attaching all pertinent screenshots. Any help is appreciated. (Forget the midi clock in option, that got selected when I was taking the screenshot after the tests by mistake trying to click the viewport in Blender again).

Hi MechaX, for some reason I cannot reproduce the interface state you have. Is it Blender 2.82 ? There are some icons I don’t have here.

I think for some reason your GUI configuration prevent the use of the snap function. That’s weird.

I did a short test here with my Linux version of B2.82 and was able to use “create realtime route” without problem.

You can if you want configure manually the route like this:

I was able to switch the snap switch with the modwheel of my MIDI keyboard.
I had to enter the expression ‘IN> 1’ (as shown on the picture) so that every value above 1 are converted to 1.

This is needed as the “use_snap” property requires 0 or 1 and will refuse a different value.

Hi @JPfeP. Thanks for the response.

Yes, I’m using Blender 2.82.a .What icons are you mentioning? Ones inside AR (AddRoutes) tab, or ones in my Blender interface?

I followed your steps indicated and got the following: (Notice the warning sign in the add on tab)

*update

I am a musician, record engineer, and I know things can be tricky when working with midi, specially in Windows. Drivers, usb busses that allow certain devices to work and others that not, really complicated but ridiculous system config that stops these things from working, that vary from computer to computer.

Where would you recommend me to start looking to get AR up and running?

Honestly, atm I just want to right click and “create a realtime route” hotkey and keep working. Then I’ll go deeper into AR and use sliders for camera movements and all that using the other options available.

That this plugin doesn’t work in my machine doesn’t mean it won’t work in others. Probably it’s just the config I have in my computer at this time, I have a bunch of Daws and music software that use midi, that can be part of the problem. I used Midi-Ox to make sure that my Launchpad was sending midi data and that my computer was processing it and receiving it. So that’s checked out.

This is one is one of the best plugins ever in my opinion for Blender.

The Launchpad Hotkey Pad will make me work faster, I’ll have more options at hand so I’ll use different approaches, I can swap easily between modes, and won’t have to do big finger stretches pressing down 3 keys, that way keeping my hands healthier.

I advise to change the AR download to something like “AddRoutes.1.0.zip” instead of “AddRoutes_latest.zip”. It’s confusing. I downloaded it 5 days ago. Example, is that still considered “the latest”?

I’m going to do some research these weeks, as I am very busy, and try to see where my system is failing, and get it to work. And I’ll post it here. Probably it’s just a minor obvious thing that requires some thinking with a clear mind.

If you or any other user can give me any recommendation do please post them here, as I’ll be checking out AR as frequent as possible till I get it to work. Regards and all the best.

Thanks for your feedback. Indeed it would be nice to get the versioned zip not the “AddRoutes_latest.zip", and even access to a directory with all the previous versions for testing.

I have been able to reproduce the greyed out “create realtime route” trouble, by accident. It happens in some context and I have changed that in the version I am going to release in the next few days.

Something that might help you to get going is to open blender from a terminal CLI and when in your project, enable Debug in the MIDI Config Panel. You should see some information in the terminal when a midi event is received.

I just released AddRoutes version 0.27 with the bug fix for “Create realtime route” and a few more for Blemote. More here :

http://www.jpfep.net/addroutes-v027/

1 Like

Thanks for the info about the terminal, it is very useful. I was just about to post a question on how to see midi information coming in to Blender this next week.

Later this evening I’m giving v.0.27 a spin, sounds really promising. As I said before, I am a big fan of using controllers, assigning them to hotkeys, so I don’t have my hand holding and gripping the mouse, fingers in the keyboard the whole time, besides other functions that can be applied to sliders and knobs like controlling Values. I’m sure this will come in handy to a lot of people as well. Best of luck!

Will post how it goes with my config next week!

There is in the pipeline the project to add support for joysticks, and on some OS (Linux for now), it’s possible to isolate keyboard and mouse from the desktop to have them as cheap controllers. I am a little busy on many fronts, but it’s a matter of time.

I understand, I am doing many things as well at the same time.

Tonight I’m installing the new version of AddRoutes and taking it for a spin.

The coming support for joysticks is fantastic, I know they are very useful in live and production situations in Ableton Live, that can translate well to Blender. I find very useful for many things the additional isolated controllers. I’ll wait till it comes around for Windows.

You should put it up in GumRoad as PWUW, when you know it’s working as intended.