after rendering, blender hangs up, i have to restart it...


(Raiden) #1

Hi, i’m new to blender and bought the (german) official blender 2.0 Guide in order to lern how to work with blender. so i load the first file (stage.blend), click on Render, and when it is complete rendered, blender
hangs up, but with every file, so alwas when i want wo render a pic, or when i click on Anim to render an animation. :frowning: so what to do? does anyone know, why it hangs up after rendering? - i use it in windows

bye

Steven

(Mo42) #2

Hi!
I’m new to blender too, but I know this problem. I had the same situation a few times, but not always. I am using Blender 2.23 on Debian/GNU Linux, so I think that is not OS-dependent.
But I did not find the reason for it. :frowning:

Moritz


(Raiden) #3

hmm, i hope someone knows the reason and how to avoid this problem…

so please help me/us!

bye

steven


(gryphon) #4

I think that in both of your cases, it might be related to graphics drivers.

Raiden: What version of Windows are you using? What kind of graphics card do you have? Do you have the most recent drivers? Did you get the most recent version of DirectX? http://www.microsoft.com/directx

Mo42: Once more, what kind of graphics card do you have, and do you have the most recent version of the drivers for it? Are you using the Static or the Dynamic version of Blender?


(Mo42) #5

I am using a NVIDIA-card (RIVA TNT2 Model 64) with the latest (closed-source) drivers from www.nvidia.com.
I don’t know if this happend with the static or dynamic version of Blender, I used both because I had some problem with the dynamic version, which were gone with new XFree packages (using debian with experimental XFree4.2 packages, perhaps that is the reason?). But I think that it was the dynamic version.


(shibbydude) #6

gryphon: Blender uses OpenGL, not directx. All of Blender uses OpenGL intensively, even the GUI uses GL. The problem would not be related to directx drivers at all. The graphics card drivers would though. I know that Blender works fine with my old graphics card drivers and not my new ones though, so… risky. I have a Radeon 7000 PCI (sucks) with 32 megs and 256 megs of system RAM. Works great! It also depends on system resources like the amount of system RAM and the other programs you have using resources - Blender can be very resource intensive. Sounds like you might need more system RAM and or it might be a registry problem with Windows / not sure about the Linux system. Anyway…

For Windows just unload some programs and then if that doesn’t help then add more RAM. Even if your CPU sucks like mine, adding ram will speed your system up and make it much more stable. Also IMHO no one should have integrated graphics. If you have integrated graphics Blender may not ever run decently. They should stop making that crap. It’s not good for Blender or any other program :). Good luck then!


(TazyTiggy) #7

Blender does work with Direct X, I was having problems with disappearing windows, buttons and such with direct x 8.1, then a changed to 8.0a and all the problems are gone. Only problem I have now is when I try to render big pictures. I can render 640x480 and smaller with no problems, but as soon as a try to go bigger blender freezes, and my computer restarts. I have Windows XP, and a nvida tnt2 graphics card with updated drivers.


(kattkieru) #8

If you’re rendering to a window, you might try rendering to a view instead. Rendering to a window hangs blender on many systems currently, or causes segfaults. I know that rendering to a view fixed the problem for me under Mac OS X.


(TazyTiggy) #9

Rendering in the 3d window is not a problem, or the smaller size. But sometimes I want a bigger picture, and it just will not work. When my computer turns back on, and I log in again XP tells me that my graphics card caused the problem. Before I upgraded to XP I had no problems with Blender (aside from a OpenGL problem that I fixed), I was using 98. Also seems like upgrading is a bad idea on my system, I also upgraded my graphics card from a Voodoo 3d to the Nvida and caused all kinds of problems. The only upgrade that hasn’t caused problems that I know of was more memory.:frowning:


(banana_sock) #10

i had a problem very similar to this so hopefully the solution works. When i downloaded the latest drivers for my graphics card (the nvidia whatever, can’t remember really) blender had some real problems. To fix the problem, i just turned down the hardware acceleration (right click on desktop, properties, settings tab, advanced, troubleshooting, then a slider) to the second lowest and blender works fine afterwards. I always put it back afterwards cos you get problems with other programs, but blender works fine.