After Windows reinstallation, Blender's Object and Edit modes jerking like crazy

Previously Blender worked perfectly for me, rarely any slowdown unless there’s an absurdly high amount of vertices or something. Due to a massive computer issue, I had to reinstall Windows 8.1 entirely, and lost everything that wasn’t backed up.

I reinstalled Blender 2.49b (the version I use), Python 2.6.2, and my graphics card’s latest drivers (Radeon, latest 14.12 Omega version of the drivers). As stated, previously I had no issues. Now every single time I enter Object or Edit modes, I get some serious slowdown/jerking, but Texture Paint doesn’t slowdown at all.

What could be causing this? It’s making Blender nearly unusable, and considering I often worked with Blender maybe 4 hours a day as a hobby for a very long time now, this is a pretty bad problem. :no:

EDIT: Upon further investigating, I found that if I use Blender right after turning on my computer, sometimes it runs silky smooth again, but othertimes it doesn’t. This is really frustrating me.
EDIT 2: After further investigating, I found that changing OpenGL “Wait for verticle Refresh” options briefly fixes the problem. It runs silky smooth again for about 10 seconds, then starts jerking a lot again. I change the Wait for Verticle Refresh again, and 10 seconds of smooth then jerkiness again follow.

I know my graphics card is not about to break or anything, because every other 3d program I run on it (DirectX or OpenGL, doesn’t matter) runs perfectly fine.

I found a solution, which I will post since no one seems to have posted anyway for anyone else that has this issue in the future.
This is a problem with OpenGL (which Blender uses) on the latest AMD Radeon drivers. In order to fix this, you need to do three things in this order:
1 - Change “Wait for Verticle Refresh” to “Always On” in the Catalyst Control Center
2 - Change “OpenGL Triple Buffering” to “On” in the Catalyst Control Center
3 - Add 4 specific DLL files from a previous AMD Catalyst Driver version (I used 14.4) to the root where Blender.exe is located. They can be found here, for a OpenGL/AMD Radeon issue from a game called “Second Life”:

Upon doing those three things, Blender is as smooth as ever once again.