Agoose77's Multiplayer Addon Issues

I am using Agoose77’s wonderful mulitplayer addon. It is wonderful! However, I can’t seem to get it to work over my local wifi. I have port forwarded ports 1200 and 1201. I included a blender file. Please let me know what is wrong. Also I can not get the random spawn to work.

Password: tanked

http://www.pasteall.org/blend/24550

How exactly do you start a server or how is it supposed to work ? How do i test this ? I think you need a client but you also need a server , lol. The blend file says client.blend but where is the server ?

I tried to find out why is you file so big and it turns out it’s the textures. The animated textures are bugged too killing the framerate completely. Here is a modified version.

Attachments

Tank006.blend (536 KB)

Will take a look at some point

The server is created by simply opening another blender window, going to the logic editor, initiating the add-on, and then choosing the server option. Then just hit P and that it. I believe.

Sorry for the huge file size. For some reason I have never been able to find a way to delete a unused texture from Blender. It is probably a super easy thing to do, but I couldn’t figure it out. Sorry about that.

I appreciate it agoose77!!! Thanks!

When you unlink a texture from an object (or unlink anything from anything, be it a texture, a material, an animation, etc.), instead of just clicking the little X on the side of the box, shiftclick it. That will unlink the texture/material, and set its users to 0. If a material or texture or animation or whatever has no users when the file is closed, it is deleted from the file.

How in the world did you create that smoke!!! It looks amazing!

I’ve seen better smoke in bge …sorry english :smiley:

I couldn’t find a better tutorial. Where are you all getting this great looking smoke?

addon_1.6.6.zip (22.1 KB)
It seems there were some serious bugs in the addon, which I’ve fixed. New version also boasts the ability to host a server and play as a client in the same game, and doesn’t freeze on connection.
The code itself is quite old, and I’ve no intention on cleaning it further, save for bug fixing (in other words, it’s not a good example for coders!)

It doesn’t want to install on my PC. I removed the old version, choose the .zip file and it doesn’t install. Here is what the console spits out: http://www.pasteall.org/pic/60806

addon_1.6.8.zip (22.3 KB)Added new fix for properties. This should install. But delete all data created by the old addon.

I’m using blender 2.68a and I couldnt get it to install using the button in the user preferences, so I just made a new folder within the addons folder, and copied all the files the addon zip into it, and the addon then finally showed up in the list under user preferences, but then when I tried to enable it I got this error.


How do I get this add-on anyways…?
nevermind, I found it
oh thanks mrn…will the binged version be the same(first link)
and yes, I do use bing :slight_smile:

what extention is the file that agoose77 posted? Whenever I download it, it always gives me a .php file that will only open in Code Writer, a W8 App
nevermind…I just put it a .zip file extetion…

I ask a question and then answer it…wow

Sorry if I’m an nub when it comes to add-ons, but how do you use this…? as in how would you install this?

right above my post

its just a .zip file, but you shouldnt need to actually open the file itself. Just drag it to your desktop.

already tried to…doesn’t work…I did user prefs, addons, and install from file…but nothing shows up in my user tab

For some reason, the 1.6.5 download works, but not the 1.6.8 version…

Actually the very latest one is only on the forums I believe and it works for me

Sent from my Nexus 5 using Tapatalk

agoose, what version of blender are you using?

2.68 I last tested. It should work with the latest release.

Sent from my Nexus 5 using Tapatalk