Ahahah Transparency Issues

I know I sorta asked the same question…kinda…sorta before but. Anyway.

Um. It’s screwing up. I’m sure it’s a simple fix!

Secondly. Ugly line there. How do I get rid of it?



There are a few rules when it comes to alpha to get the most optimal sorting. However, I don’t remember all of them. One I do remember is to not mix alpha and opaque meshes. So, if you’re ears are done with an alpha map, I’d separate them from the rest of the mesh. Also, make sure Ztransp is enabled.

You mean separate as in a different texture? Ztrans is enabled. :3

looks like some normals are pointing into the incorrect direction.

I mean separate as in a different mesh. The second picture is definitely alpha sorting problems.

I do not understand, why everything is alpha.
Alpha faces slow down the rasterizer and produce such problems.

Only enable alpha on faces that will use it- the rest should be set to solid. You can leave them in the same mesh (Sometimes you have to, if you want to have a non-alpha face connected to an alpha one) but you should make sure in the face settings that every face that doesn’t use alpha is set to opaque. You might also need to give them a different material that doesn’t use alpha, sometimes the material settings override the face settings.

Additionally, it looks like your alpha usage would do just fine with clip alpha, which is much faster and doesn’t have sorting issues- the difference is it’s either fully opaque, or fully transparent. There’s no middle ground. In your case, that should be just fine.

I see. Well, that’s certainly not a problem! Hahahahah. So, how do I use clip alpha?

I don’t know how to set it to where only the ears and the hair bits would use the Alpha. :3

Thank you for all your comments!

Ah, sometimes I forget that not everyone knows where the face settings are. Go into edit mode, and you’ll find the settings in the buttons window, right next to the UV calculation tab. Select all the faces you want to be clip alpha, click on “clip alpha”, and then hit copy face mode. Then select all the other faces (ctrl-i to invert the selection), hit opaque, and hit copy face mode.

D: DURRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR. I always wondered where that was, AHAHAHAHAHAHA. Bangs head I really, really should invest some time some day to actually playing around with buttons.

AND YAY!!! It’s a miracle and did I mention just how much I love you? Hahaha. Thanks!