Aliasing problem with object index

I have a scene with a number of meshes with different object indexes.

When I use an ID mask node to view them I am finding that they are all unaliased. I have tried turning on smooth mask but I lose some of the mask by doing this.

How do I get aliased masks using object index?

I have Anti-Aliasing switched on in the render settings by the way.

Thanks in advance,


anti-aliasing does not happen on render passes… as they are all evaluated on a per pixel basis.

if you are wanting to make your own pass… colour your object pure white… and the rest of the scene pure black and render… use that as a mask.

Thanks for the answer, yes I’ve been making my own mattes so far using materials.

Why are the passes like this? Defeats the purpose of them no? Or am I missing something?