All Armature bones are Zero

Hey folks,
I have here a “invisible” Armature. All looks good in Edit Mode and in Rest-Position but for some reason, I cant figure out why, all Bone Positions and Scales seem to be zero.
I’ve managed to select the armature via Outliner and made a copy which isnt connected to any mesh.
The copy behaves the same way, all bone constraints are disabled, all bone layers are visible, restarted blender (2.79)
Problem still exists.

All Bones become visible when I set it to “Envelope”. Every bone is just a circle (Bone Length Zero), centered around the Armatures Center (Bone Postion Zero),

I was just editing along an all of a sudden…
I have no idea whats happening there.
I have version 2.79 on Windows 7.

I’ve just made Apply Pose as Rest Pose.
I got this message:

Actions on this armature will be destroyed by this new rest pose as the transforms stored are relative to the old rest pose

That has fixed it for the current frame.
Selecting another frame made it come back however.
I deleted all keyframes in the graph editor (luckily it wasnt much).
Now its all fine again.
I still wonder whats going on there…

What happens if you set the armature to rest position?

it showed up exactly as it should. The 2nd screenshot shows the armature in rest position.

Can you go into pose mode, select all, and Alt-S (remove scale) Alt-R (remove rotation) Alt-G (remove possession)

that actually was the first thing i’ve done.
Now that its fixed i tried to reproduce it, I fuzzily feel like its something with keyframes and/or pose library but not shure at all.