Alpha-Background after compositing black

Hi there!
Perhaps anyone of you guys got a solution for me.
I can’t get a transparent background after the compositor. I use IdMasks + Glare nodes + cures and mix nodes.
Blender renders everything transparent but when the compositor is taken into effect the background becomes black… anyone got any ideas how to stay with a tranparent background?

PS: Settings are - Under render/Films Transparency is set, used rgb and rgba, render/opengl render/alpha is set to transparent not sky (didn’t work with sky eiter). Thx for any responses!

Well… I narrowed it down. I am pretty sure about the node producing the black background. Unfortunately I have no idea what workaround I could use. Here you see my nodes:

The mix node adds in the black colour. When I add in the image from render layers 2 times into the mix node I get the transparent background but in the backdrop I can’t see the glare anymore… anyone got any ideas?