Alpha Channel


(imatthew) #1

I used a blend texture in order to make a banner fade out. I used Alpha
and made the blend from white to black. This works pretty good except that when there is an object in front of what is transparent you then can see the outline of this object. Even if I turn the alpha of the object that is causing the outline to 0 you can still see it.

Anyone know what is going on here?


(blengine) #2

select the object and in the material settings turn ZTRANSPARENCY on, that should do the trick…if not, come back and yell at me =)


(S68) #3

Transparent objects, sadly, cast and receive shadows…

Stefano


(SirDude) #4

You could use 2 scenes where one does not have the
object you want faded out, but has everything else.
Then use the wipeout sequence plugin to do your fade.


(Dinklebrow) #5

You can also try this.
Put the object that you applied transparency in a different layer. Create a copy of your lights (just the one’s that will have influence on the object), put them in the layer with the transp. object and press the layer button-Lamp Buttons F4-for the new light. Turn off shadow for the new lights (if spots) Now for the original lights press the layer button. If you have more than one layer with objects, just shift-select each layer that has the other objects in it.

hope you can understand my ramblings.


(haunt_house) #6

maybe I don´t get it, but why not simply disable ‘tracable’ for the object to not cast a shadow? :-?

haunt_house


(Dinklebrow) #7

Disabling tracing will still give you the outline of the object that has transparency. It will just not cast shadows. I also forgot to tell you to turn on Ztransp in the Material Buttons.

Image with trace off
http://www.crosscannon.com/trace-off.jpg

Image with trace on
http://www.crosscannon.com/trace-on.jpg

Image with ztransp on. Notice the outline of the mesh.
http://www.crosscannon.com/ztransp-on.jpg

Image with light/objects own layer, Ztransp on.
http://www.crosscannon.com/light-layer.jpg


(pofo) #8

I don’t really see why that would be better than:

http://w1.185.telia.com/~u18510119/test.jpg

ztransp on, trace off

Perhaps I misunderstood the reason for the layer trick?

  1. pofo

(haunt_house) #9

You are of course right, Dinklebrow

but the ztrans setting was answered already, so I didn´t care to mention it anymore.

HH


(Dinklebrow) #10

I forgot that someone already had mentioned the ztrans setting in an earlier reply.

pofo: You are right, it doesn’t matter, I like that way better than the layer way.