Alpha Channels on AVI

Couple of questions: Does Blender support the alpha channel in Indeo 5.1?

I am applying some greenscreened footage to a plane in Blender (the green has been processed out in Zwei-Stein and the background is now pure black) and trying to remove the background. I thought I would get away with just using the Indeo 5.1 codec cos it says it has an alpha channel but no dice. Although Blender seems to be detecting the alpha cos it sets UseAlpha on by default, it doesn’t actually cut the mask away automatically. (either Blender is not reading the alpha or Zwei-Stein did not render the alpha correctly)

So currently I am using two AVI’s, in two texture channels. One with the movie and one with a black and white mask of the movie.

That’s working fine but if I could save myself the hassle of rendering out the seperate mask I’d like to know.

Anyone help?

PS Zwei-Stein can’t render out Targa pics in this version so that is not an option

I’ve never heard of any AVI codecs that support transparency, but then again I generally use a series of TGA files. My suggestion is to render out a frame into TGA format and open it in an image editing program that has support for alpha channels. This will just ensure that the alpha is correctly being read and written in Blender.

UseAlpha does actually change the transparency of the material unless you specifically tell it to- it will just set those areas to an opaque black if you don’t. Do this by…

  1. Under the ‘Texture’ tab in the Material Buttons (F5), select the texture channel that should affect the transparency.
  2. Go to the ‘Map To’ tab and have only the green ‘Alpha’ toggle button be selected
  3. Under the ‘Mirror Transp’ tab, select either ‘ZTransp’ (if you’re not using raytraced lighting) or ‘Ray Transp’ (if you are using raytracing)
  4. Under the ‘Material’ tab, make the ‘a’ slider be equal to zero.
  5. Under the Render Buttons (F10), under the ‘format’ tab set your image type as Targa, and enable RGBA
  6. Lastly, you must enable Premul or Key in the ‘Render’ tab.

You must follow all of those steps if you intend for your rendered output to have an alpha channel with that material. I had you set the image type to Targa because I know that works. Once you get the Targa method working, you can experiment with some video codecs.