Alpha Ignored for Ray Mirror?

So I’ve been playing around with texturing. My end goal is going to be something like chalk or grease pencil on polished stone. I don’t have a clue how to do the latter so I’ve been fiddling a bit, and I found something that seems really strange.

I’ve got this stone thing here, and it’s working ok:

http://img510.imageshack.us/img510/7133/concreteglossxd1.th.jpg

Then I try to add an image texture on top of that. So far it’s just a 30 second gimp doodle that I’ll later replace with an actual design and all. Since I don’t want the drawing to be reflective, I hit the invert ray mirror button and:

http://img410.imageshack.us/img410/5268/concreteshinewr4.th.jpg

The non-white parts of the image go to full-reflect, ignoring the alpha channel in favor of what the image looks like in the texture preview if I DON’T hit the alpha button.

Am I just not understanding how this is supposed to work, or is this some kind of bug?

Here’s the material setup:

http://img410.imageshack.us/img410/2032/concretescreenwa5.th.jpg

Thanks :slight_smile:

You say that u added the texture but u actually mixed it.Maybe “multiply” option will do. Give a try.

I meant added the image to the texture list / material, wasn’t thinking of mix modes at that point. Hmm.

Yay, more confusion.

I’ve been trying to just use the image I have as a reflection map; the problem is that it’s the wrong polarity. No problem, I thought: I hit the ‘NEG’ button in Map To. … And found that it dosn’t seem to have any effect on images with alpha enabled. In that sense, I suppose, alpha is behaving more or less as it should.

NEG does work as intended if I turn off Use Alpha, but that causes other problems.

Goes back to gimp to see if he can make some more useful maps.

see texture channel mix modes in the wiki. wiki is down right now so i can’t give you the link.

Attachments


Hmm, that could be. I was just trying to do something like that with nodes and not having much luck. The idea being since the two materials are substantially different they should come from different mat nodes, but the reflection and patterning from the stone material were showing through the lines in the other one in any case that involved both of them showing. I even tried using the alpha or a mask texture as the input factor for the mix/overlay node and didn’t get what I wanted.

Where’s AlphaOver when you need it -_-.

Thanks :slight_smile:

Have you tried setting DVar to 0 in the Map To panel and the blending mode to mix? When I set up a material similar to yours that seemed to do what you’re looking for.

The final RayMir value is calculated by taking the original RayMir value (0.3 in your case) and mixing it with DVar (1.0 in your case) according to the Blend Mode (Mix in your case), so the final result will be somewhere between 0.3 and 1.0. Since you want the value to vary between 0.3 and 0.0, lower DVar all of the way.

The Blending mode then affects whether black or white is mapped to DVar.

Also, you probably want “No RGB” to be checked as well so that the image is treated as greyscale like you want…

Dude, thanks. I read some stuff about DVar and about how to do X you need to set it to zero (tho I don’t remember know what X was); but I didn’t quite get what it actually did till now and I think I do. Still have to play with it which won’t bebore a while.

Um … the image was pretty much white on black / alpha, so if there was any non-greyscale stuff in it it was blurry-brush artifacts or something. Does norgb still help in this case?