alpha in compositing problem

hello guys, I’m not sure if this has been already been asked,
in BI when I want to composite my renders I usually check “sky” under render layers panel, I get my alphas for the objects scenes and thats good,

but here is my problem,
in cycles the equivalent thing is “use environment”, I check it, but I dont get my alphas !! is it a bug, or do they changed it , any way you get the idea ,

by the way I’m using the latest version 2.7, I even got the same thing on an official built,

I know I’m probably doing something wrong :stuck_out_tongue:

ps: I know of some dirty tricks to get the alpha (like pass index or from another scene with the BI render) but I wanna know if I’m wrong or is it a bug.

In the properties panel, in the render settings, go down to film and check transparent.

hhhh! knew its gonna be somewhere :stuck_out_tongue: , thanks you Rich!!