Alpha in rendered pictures (again)


(tmohr) #1

Hi,

i try to render a picture that has (instead of a black background)
an invisible background, so when i load it in e.g. gimp i can overlay
it over another picture.

I received the hint to press “Premul” or “Key” in the render menu.

But this didn’t help, when i save a picture (raw TGA) it has a black background.

I use blender 2.2.3 on Linux.

I also tried to add a “world”, but this also didn’t seem to help.

Has anybody got a hint for me?

Best regards,
Torsten.


(RipSting) #2

You didn’t mention if you’re rendering RGB or RGBA. Since you want an alpha channel, you need to press the RGBA button in the display buttons (F10). You don’t want any world settings or the background will become opaque.

If you can’t find a way for this to work, try turning off anti-aliasing (OSA) and make a bright green (or another distinct color) background color in the world buttons. When you import it into Gimp I think you’re able to select by color, so you can simply delete all the green. This method will leave you with jagged edges though.


(rwenzlaff) #3

There’s also a bug in the TGA alpha code that apperently only effects the Gimp.

If you had 2.25 you could use PNGs. Luckily, Gimp supports the IRIS format and the transperency works OK. Files are pretty large, though…

Bob


(tmohr) #4

Hi,

thanks for that hint, saving an IRIS works great!

But what about 2.25, where can i download it?

Regards,
Torsten.