Alpha layer makes volumetric spotlight invisible

Hi all,
I have a basic scene that i split in two render layers…one is the scene, the other one is just for a volumetric spotlight.

It’s all fine in this way, but when i check the “transparent” under Render->Film and uncheck the Use Environment in both layers …the volumetric light disappears in the render.

Is there any way to fix this? I’m using Cycles and Blender 2.71.5

Thanks in advance