Alpha object/material animation

I’m trying to get an object to fade in to an animation.
The trouble I have is that setting the 0 and 1 Material Alpha keyframes makes the object appear black against the object from which it protrudes, then fade to white.
What I want is to have the object and material fade from completely invisible to fully visible.

I’m befuddled. I attached the .blend in case that would be helpful.

Attachments

test.blend (745 KB)

You´ve got to activate the Ztransp option in the material menu.

Thank you so very much! I’m extremely grateful for this forum and the brilliant, knowledgeable, and helpful artists here. Blender is amazing. It’s just sometimes difficult to find how to do the exact thing I’m thinking of without help.

BTW, nice website there, jpbouza. I’m downloading now. :eyebrowlift:

When I enabled the Ztransp, the material preview went transparent, but in the render, I’m still not getting full transparency in frame 210 - then to fade in to full opacity. The object pops in semi-transparent. I tried tweaking the Alpha IPO curve, but it didn’t help.

What else am I missing? :confused:

Attachments

test1.blend (745 KB)