alpha over alpha !!

i have created a racing track , and the boundries were trees (textures on plans) … now when the viewport displays two alpha textures each of them is above the other then the textures blend to each other and non of them covers the other … is there a solvant ??


You mean that a alpha texture behind another alpha texture is showing on top? This can be changes by using the: Ztransp in materials -> mirror transparanty tab. It’s a bug that still shows up and can be fixed by a simple OpenGL code, and I think Erwin did that cause in the 2.41 it doesn’t show the alpha bug anymore, well I tried to recreate but it doesn’t show up :smiley:

I feel your pain :stuck_out_tongue: this is a common problem and it’s to do with the z-buffering. I’m not going to go into all the details, but it’s a 3D process used to calculate the way perspective works by drawing the closer pixles first, this can cause problems in alpha because it shows up the faking perspective flaw which causes overlapping.

It has not been fixed in 2.41 (I have just tested it) there is no way to fix it anyway unless you use a different processing method. The same also happens in shockwave because it uses Z-buffering too. Apart from it’s annoying bug with transparency, Z-buffering is the best and most realistic way to fake 3D…

From Daniel

can they build this into the game engine?

# This script must be run every frame to keep depth testing
# enabled. To disable alpha testing, just stop running the
# script. Blender will automaticly reset itself the next
# frame.

from Blender import BGL

BGL.glAlphaFunc(BGL.GL_GREATER, 0.5)

# That's it! When you remove the texture loader and 3D
# renderer, this is all that's needed to enable alpha
# testing for Blender's renderer.

thank you all :stuck_out_tongue: … lets listen to more members lol …