Alpha Over - Is just performing as if was "mix" shader?!

Please see attached gallery (there are two images):

Put simply, there big black plane inside the white frame rendered in the background is setup as a holdout. You can see the inputs and alphaover node on the side. The alphaover isn’t working properly.

In order to have the image representing the things inside the picture frame appear where the black plane is, I have to drag the FAC slider, and whilst this does make the inside picture image fade in (it’s not completely there until the fac is all the way over to 0.

The problem is, as soon as the FAC of this is moved from fully 1, the concrete room and frame, of the rendered scene, starts to darken and fade away, meaning this is effectively just a standard colour mix shader. When a render of the scene is underway, rather than leave the black holdout plane/portal blank, it’s rendering blackness, which it shouldn’t if its classed as holdout, it should just be see through. Does anyone know how to fix this?

I have solved my own issue!

If any has similar problems to this, your problem may be solved by going into the render settings for the scene, and in the FILM section, ticking the transparency option.