Alpha over... or similar?


I’ve split a scene into 3, (near, mid and far). There are trees which use raytraced transparency for the leaves, these are pre-multiplied.

For the nearer two scenes, under layers i’ve un-checked ‘sky’, set the file type to RGBA and upped AA to 16, and also tried ‘Full sample’.

With the three files I use a separate file to composite them using ‘Alpha over’, with the following result:


As you should notice i’m getting edges around the leaves on the trees in the foreground.

Where am I going wrong, or what other method should I be using?


did you select “convert premultiply” in the alpha over node?



I’ve also tried setting ‘Premultiply’ to 1 as well.

My solution would be as follows:

  1. Image with trees should be rendered with with Alpha mode: Straight.


To mix this one I’d use regular Mix node (Mix blend mode). I’d use the image with trees as second input (lower one) and check “Include Alpha of second input…” option. Set Factor to 1.

Should work fine.

The problems arise from premultiplication. You shouldn’t have premultiplied the image when rendered.
This leads to RGB values that are premultiplied by alpha, so on the edges you have darker RGB.