Alpha overlay not rendering correctly in Eevee, but display correctly in viewport

I have two textures with transparency overlaying on top of each other (the hair, as a multiple alpha overlay) via Material nodes. At first the overlay would not display correctly (one texture would cancel the other out), which I solved following this thread.

I solved the problem in the viewport, however when I render the image the alpha textures again display incorrectly:

Playing with the material settings did not change the rendered result. I’m not sure how to go about solving this - any help is appreciated and thank you!

I FOUND THE SOLUTION:

The Solidify Modifier (for correct backface culling) wasn’t enabled in the render view, only in viewport :woman_facepalming:t2:

hello! don’t forget to tag it solved for a better website experience.

thanks! new here so didn’t know I could do that :slight_smile: tagged now!

1 Like