Alpha Problem in Blender Publisher 2.25!!!

As the Screenshoot shows Publisher 2.25 has a Problem whit alpha…
Somewhere I think I read a solution for this Problem – but I cant find it any more…
If someone could Help me that would be great and It would make the 3D Power Tower Project even better…
Also it would be great If this Problem could be solved and also work in a .exe
Thanx for all Ideas and Help


That’s why we have Blender 2.45 :eyebrowlift2:

Or better would be the 2.46 beta (or the release once it happens…) :slight_smile:


Yea but since the 3d Power Tower project is based on 2.25 I need a solution for this version…

Then unless you can find someone to merge the new GE renderer into 2.25, i doubt there is anything one can do.

But im sure that I once read something on how you can do it in 2.25 but i just cant finde it anymore… hope somone also can remember the post/articel… And can help me… That would just be great and Improfe the the 3D Power Tower Project
Please Help me…

I don’t believe it is possible with blender 2.25 because the source code was never released for 2.25 (I could be wrong though). The only way to fix the problem is through fixing the 2.25 source code, or by merging the new GE renderer into the 2.25 source code.

and we’ve almost always had this problem, It’s not fixed in 2.45.

Maybe. But in 2.4x, one can simply set the tree to use 1bit alpha test (Z-transp in the material panel) as oppose to alpha blending. This will resolve the overdraw issue seen here.

I also asked this Question in and this is the Answer I got:

In Blender, select an object (With another object in front of it), go to the Object buttons (F7), find the Draw box, and activate X-ray. That’s the effect I believe we’re trying to get.

But I dont quite understand it… Will It work and if so how and Why?

Okay I now now that X-Ray dose not exist in Blender Publisher 2.25… :frowning:
Any other Ideas?

The z transparent thing never worked for me.

GAH!!! the alpha problem is gone in 2.46 RC! !!! i just tried it… not overlaping!!!

Yea… Great… But for this Project I need a solution for Blender 2.25…:frowning:

Okay the Admin of 3DPowerTower Dieter1a has found a Solution for this Problem (He is the one that I asked this question in the first place - for as most of you probably know I my self i’m using the newer GE Versions(… I have to over think if I dont whant to change to 2.25 myself… It runs whit much les errors , uses les space (A building like the 3D PowerTower would use a few 100Mbs in the new version and as it is it only uses 23MB , and seams to be able to do allmost everything that the new versions can do…)
Okay here is the Link to the Solution (Its in German):
For the ones that do not speak German here the Links of the files (note you can only open them in 2.25)
The Blend File:
A English topic that handels this Problem:
And the Arcive file:
Use Start to start the Demo.
Use BlenderPublisher to open the .Blend
Hope this will help all the other people dealing whit this Problem…

In the Name of Dieter1a the Project Leader of I have the honour to thank He-blend very much for his great Alpha Script.
Many thanks from myself to