Alpha problem with Quixel Plant

Hi! I am having artifacts when I import plants from megascans:

If you check the green leaves they have a pixelated edge in certain areas.

The node setup looks like this:

Do you know what it could be ?

I found the solution. If you are experiencing problems with the opacity maps coming from Quixel what you need to do is add a Math node to the Opacity texture and set it at “greater than” …and play with the thresholds. This will take away the grey noise from the edges by only filtering Black and white.

You can also use the color ramp and set it to constant instead and attach it to the opacity node…play with the handles til you get rid of the non 100% black and White values.

Alternately, you can pop over to material properties, head to the settings tab, and play with your blend modes and/or clipping threshold.

1 Like

Great ! thank you!